zoukankan      html  css  js  c++  java
  • poj1260——线性dp

    poj1260——线性dp

    Pearls
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 7705   Accepted: 3811

    Description

    In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family.In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class. 
    Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl. 
    Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the 
    prices remain the same. 
    For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro. 
    The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program. 

    Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one. 

    Input

    The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1<=c<=100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai needed in a class (1 <= ai <= 1000). 
    The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers. 

    Output

    For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list. 

    Sample Input

    2
    2
    100 1
    100 2
    3
    1 10
    1 11
    100 12

    Sample Output

    330
    1344
    题意:要买若干种价值的珍珠,但买某种珍珠必须多付10颗此种珍珠的价钱,及如果买价值为1的珍珠100颗,必须付的钱数为110。一颗珍珠可以用比它贵的珍珠 充数,因此买多种珍珠的时候用贵的代替便宜的可能更省钱。例如买100颗价值为2的、1颗价值为1的,此时买101颗价值为2的为较优方案。输入要买的若 干种珍珠,可用高价珍珠充数的条件下,问最少需要花费多少钱。
    注意:题目的价格已给出升序
    思路: dp[i]=min(dp[i],dp[j]+(a[j+1]+a[j+2]+...+a[i]+10)*p[i])=min(dp[i],dp[j]+(sum[i]-sum[j]+10)*p[i])
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cstdlib>
    #include<algorithm>
    
    using namespace std;
    
    const int maxn=1000100;
    const int INF=(1<<28);
    int T;
    int c;
    int a[maxn],p[maxn];
    int dp[maxn];
    int sum[maxn];
    
    int main()
    {
        cin>>T;
        while(T--){
            cin>>c;
            a[0]=0;
            for(int i=1;i<=c;i++){
                cin>>a[i]>>p[i];
                sum[i]=sum[i-1]+a[i];
            }
            dp[0]=0;
            for(int i=1;i<=c;i++) dp[i]=INF;
            for(int i=1;i<=c;i++){
                for(int j=0;j<i;j++){
                    dp[i]=min(dp[i],dp[j]+(sum[i]-sum[j]+10)*p[i]);
                }
            }
            cout<<dp[c]<<endl;
        }
        return 0;
    }
    View Code
    没有AC不了的题,只有不努力的ACMER!
  • 相关阅读:
    日期时间检查(格式为:YYYY-MM-DD HH:MM:SS)
    日期合法性验证(格式为:YYYY-MM-DD或YYYY/MM/DD )
    [转]Attribute在.net编程中的应用
    WCF
    [转]使用C#开发ActiveX控件
    在 IIS 中承载 WCF 服务
    [转]一个完整的Installshield安装程序实例
    反射
    特性
    迭代器
  • 原文地址:https://www.cnblogs.com/--560/p/4353331.html
Copyright © 2011-2022 走看看