zoukankan      html  css  js  c++  java
  • poj2084——卡特兰数

    poj2084——卡特兰数

    Game of Connections
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 7647   Accepted: 3865

    Description

    This is a small but ancient game. You are supposed to write down the numbers 1, 2, 3, . . . , 2n - 1, 2n consecutively in clockwise order on the ground to form a circle, and then, to draw some straight line segments to connect them into number pairs. Every number must be connected to exactly one another. 
    And, no two segments are allowed to intersect. 
    It's still a simple game, isn't it? But after you've written down the 2n numbers, can you tell me in how many different ways can you connect the numbers into pairs? Life is harder, right?

    Input

    Each line of the input file will be a single positive number n, except the last line, which is a number -1. 
    You may assume that 1 <= n <= 100.

    Output

    For each n, print in a single line the number of ways to connect the 2n numbers into pairs.

    Sample Input

    2
    3
    -1

    Sample Output

    2
    5
    题意:一圆环上有2n个点,求两两连线且不交叉的方法数。
    思路:卡特兰数
    import java.io.*;
    import java.util.*;
    import java.math.*;
    
    public class Main {
        public static BigInteger fac(BigInteger n){
            BigInteger a=new BigInteger("1");
            BigInteger zero=new BigInteger("0");
            if(n.equals(a)||n.equals(zero)) return a;
            return n.multiply(fac(n.subtract(a)));
        }
        public static BigInteger C(BigInteger n,BigInteger k){
            return fac(n).divide(fac(k).multiply(fac(n.subtract(k))));
        }
        public static BigInteger Catlan(BigInteger n){
            BigInteger a=new BigInteger("1");
            return C(n.add(n),n).divide(n.add(a));
        }
        public static void main(String[] args){
            Scanner in=new Scanner(System.in);
            BigInteger n;
            BigInteger two=new BigInteger("2");
            BigInteger end=new BigInteger("-1");
            while(in.hasNext()){
                n=in.nextBigInteger();
                if(n.equals(end)) break;
                System.out.println(Catlan(n).toString());
            }
        }
    }
    View Code
    没有AC不了的题,只有不努力的ACMER!
  • 相关阅读:
    DBSCAN密度聚类
    特征工程之特征预处理
    特征工程之特征表达
    特征工程之特征选择
    Adaboost,GBDT和XGboost算法
    036 Go操作NSQ
    035 Go操作Redis
    034 Go操作MySQL
    033 protobuf初识
    032 二进制协议gob及msgpack介绍
  • 原文地址:https://www.cnblogs.com/--560/p/4362588.html
Copyright © 2011-2022 走看看