zoukankan      html  css  js  c++  java
  • hdu 1087 最长上升序列和 dp

    Super Jumping! Jumping! Jumping!

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 56910    Accepted Submission(s): 26385


    Problem Description
    Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



    The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
    Your task is to output the maximum value according to the given chessmen list.
     
    Input
    Input contains multiple test cases. Each test case is described in a line as follow:
    N value_1 value_2 …value_N
    It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
    A test case starting with 0 terminates the input and this test case is not to be processed.
     
    Output
    For each case, print the maximum according to rules, and one line one case.
     
    Sample Input
    3 1 3 2
    4 1 2 3 4
    4 3 3 2 1
    0
     
    Sample Output
    4
    10
    3
     
    题意:有N个数字构成的序列,求最大递增子段和,即递增子序列和的最大值,思路就是定义dp[i],表示以a[i]结尾的最大递增子段和,双重for循环,每次求出以a[i]结尾的最大递增子段和。
     
    #include<iostream>
    #include<string.h>
    using namespace std;
    int a[1005],dp[1005];
    int max(int a,int b)
    {
      return a>b?a:b;
    }
    int main()
    {
      int n;
      while(cin>>n&&n!=0)
      {
        for(int i=0;i<n;i++)
          cin>>a[i];
        memset(dp,0,sizeof(dp));
        dp[0]=a[0];
        for(int i=1;i<n;i++)
        {
          for(int j=0;j<i;j++)
          {
            if(a[i]>a[j])
              dp[i]=max(dp[i],dp[j]+a[i]);
          }
          dp[i]=max(dp[i],a[i]);
          
        }  
        int ans=dp[0];
        for(int i=1;i<n;i++)
          ans=max(ans,dp[i]);
        cout<<ans<<endl;
      }
      return 0;
    } 
  • 相关阅读:
    Linux权限对文件或者目录的影响
    Linux基础命令chmod(什么是权限?如何设置权限)
    Shell编程——素数的判断
    Shell编程——阶乘
    Shell编程——回文数
    汇编(8253计数器)
    汇编(8255A的工作方式1)
    汇编(8255A的方式0)
    汇编(程序查询方式控制输入输出)
    Shell函数、接受用户输入
  • 原文地址:https://www.cnblogs.com/-citywall123/p/11000350.html
Copyright © 2011-2022 走看看