zoukankan      html  css  js  c++  java
  • POJ 2051 Argus 优先队列

    Argus

    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 12282   Accepted: 6110

    Description

    A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.
    Query-1: "Every five minutes, retrieve the maximum temperature over the past five minutes."
    Query-2: "Return the average temperature measured on each floor over the past 10 minutes."

    We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.

    For the Argus, we use the following instruction to register a query:
    Register Q_num Period

    Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds.

    Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num.

    Input

    The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#".

    The second part is your task. This part contains only one line, which is one positive integer K (<= 10000).

    Output

    You should output the Q_num of the first K queries to return the results, one number per line.

    Sample Input

    Register 2004 200
    Register 2005 300
    #
    5
    

    Sample Output

    2004
    2005
    2004
    2004
    2005

    题意:有若干任务,给出任务的id(各个任务唯一)和执行间隔时间(每个任务不唯一);要求按照执行时间来输出前k个任务的id号; 当两个任务在同一个时间执行时,先输出id小的


    优先队列
    #include<iostream>
    #include<string>
    #include<string.h>
    #include<queue>
    using namespace std;
    struct node
    {
        int id;
        int t;
        int next_t;
    }temp;
    
    bool operator < (node x,node y)//重载小于号,从小到大排序
    {
        if(x.t==y.t)
            return x.id>y.id;
        else
            return x.t>y.t;
    }
    
    priority_queue<node>p;
    int main()
    {
        string s;
        int k;
        while(cin>>s)
        {
            if(s[0]=='#')
            {
                cin>>k;
                break;
            }
            else
            {
                cin>>temp.id>>temp.t;
                temp.next_t=temp.t;
                p.push(temp);
            }
        }
        while(k--)
        {
            temp=p.top();
            p.pop();
            cout<<temp.id<<endl;
            temp.t=temp.next_t+temp.t;//更新这个编号下一次出现的时间
            p.push(temp);//存进队列里面去
        }
        return 0;
    }

      

  • 相关阅读:
    窗口生效函数UpdateData
    查找内容grep命令
    终止函数 atexit()
    根据名字杀死进程Killall
    修改系统时间为UTC时间
    转 proc文件
    NTP算法
    转载,网线的深刻理解
    js完成密码输入为空,和两次输入不一致
    CSS初步了解
  • 原文地址:https://www.cnblogs.com/-citywall123/p/11287760.html
Copyright © 2011-2022 走看看