zoukankan      html  css  js  c++  java
  • POJ 2386 Lake Counting 八方向棋盘搜索

    Lake Counting

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 53301   Accepted: 26062

    Description

    Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

    Given a diagram of Farmer John's field, determine how many ponds he has.

    Input

    * Line 1: Two space-separated integers: N and M

    * Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

    Output

    * Line 1: The number of ponds in Farmer John's field.

    Sample Input

    10 12
    W........WW.
    .WWW.....WWW
    ....WW...WW.
    .........WW.
    .........W..
    ..W......W..
    .W.W.....WW.
    W.W.W.....W.
    .W.W......W.
    ..W.......W.

    Sample Output

    3

    Hint

    OUTPUT DETAILS:

    There are three ponds: one in the upper left, one in the lower left,and one along the right side.
    题意:W代表水塘,. 代表土地,问一共有多少个联通的水塘
     
    #include<iostream>
    #include<string.h>
    #include<string>
    #include<algorithm>
    using namespace std;
    int dir[8][2]={{0,-1},{0,1},{1,0},{-1,0},{-1,1},{1,1},{-1,-1},{1,-1}};
    char a[105][105];
    int n,m;
    int check(int x,int y)
    {
        if(x>=0&&x<n&&y>=0&&y<m&&a[x][y]=='W')
            return 1;
        else
            return 0;
    }
    void dfs(int x,int y)
    {
        if(check(x,y)==0)
            return;
        if(a[x][y]=='W')
            a[x][y]='.';
        for(int i=0;i<8;i++)
        {
            int dx,dy;
            dx=x+dir[i][0];
            dy=y+dir[i][1];
            dfs(dx,dy);
        }
    }
    int main()
    {
        cin>>n>>m;
        int cnt=0;
        for(int i=0;i<n;i++)
            cin>>a[i];
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(a[i][j]=='W')
                {
                    dfs(i,j);
                    cnt++;
                }
            }
        }
        cout<<cnt<<endl;
        return 0;
    }
  • 相关阅读:
    html+php超大视频上传功能
    html+php超大视频上传教程
    html+php超大视频上传方案
    html+php超大视频上传技术
    html+php超大视频上传实例解析
    html+php超大视频上传示例
    html+php超大视频上传实例
    矩阵求导
    概率密度
    概率分布函数
  • 原文地址:https://www.cnblogs.com/-citywall123/p/11289574.html
Copyright © 2011-2022 走看看