zoukankan      html  css  js  c++  java
  • POJ 3253 Fence Repair

    Fence Repair

    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 72404   Accepted: 23764

    Description

    Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

    FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

    Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

    Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

    Input

    Line 1: One integer N, the number of planks
    Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

    Output

    Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

    Sample Input

    3
    8
    5
    8

    Sample Output

    34

    Hint

    He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
    The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
     
    题意:输入n块木板的长度,这些木板是由一块木板切割成的,将一块木板切割成两部分的代价是这两块木板的长度之和,问切割成这n块木板的最小代价是多少
     
    题解:优先队列,逆向模拟切割木板的过程
     
    #include<iostream>
    #include<string.h>
    #include<string>
    #include<algorithm>
    #include<queue>
    #include<set>
    #define ll long long
    using namespace std;
    priority_queue<ll,vector<ll>,greater<ll> >p;
    ll n,ans;
    ll a[20005];
    int main()
    {
        while(cin>>n)
        {
            while(!p.empty())
                p.pop();
            for(int i=0;i<n;i++)
            {
                ll x;
                cin>>x;
                p.push(x);
            }
            ans=0;
            while(p.size()>1)
            {
                ll mn1,mn2;
                mn1=p.top();
                p.pop();
                mn2=p.top();
                p.pop();
                p.push(mn1+mn2);
                ans=ans+mn1+mn2;
            }
            cout<<ans<<endl;
        }
    }
     
  • 相关阅读:
    [树莓派]wifi在面板看不到,但是可以scan到的解决方案
    关于GCD的几个结论
    Ubuntu配置vncserver
    树莓派更改vnc分辨率
    玩转树莓派
    两个树莓派(或香蕉派)之间的音频直播测试
    使用树莓派录音——USB声卡
    树莓派自定义命令(给命令起别名)
    gitlab搭建
    linux下的缓存机制及清理buffer/cache/swap的方法梳理 (转)
  • 原文地址:https://www.cnblogs.com/-citywall123/p/11297579.html
Copyright © 2011-2022 走看看