zoukankan      html  css  js  c++  java
  • hdu 2222 Keywords Search 模板题

    Keywords Search

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
    Total Submission(s): 85068    Accepted Submission(s): 29646


    Problem Description
    In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
    Wiskey also wants to bring this feature to his image retrieval system.
    Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
    To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
     
    Input
    First line will contain one integer means how many cases will follow by.
    Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
    Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
    The last line is the description, and the length will be not longer than 1000000.
     
    Output
    Print how many keywords are contained in the description.
     
    Sample Input
    1
    5
    she
    he
    say
    shr
    her
    yasherhs
     
    Sample Output
    3
     
    #include<iostream>
    #include<string.h>
    #include<string>
    #include<algorithm>
    #include<queue>
    #include<set>
    #define ll long long
    using namespace std;
    int tree[400005][26],vis[400005],fail[400005];
    int t,n,cnt,id,root,num=0;
    string s,ss;
    
    void insert()//建树
    {
        root=0;
        for(int i=0;s[i];i++)
        {
            id=s[i]-'a';
            if(tree[root][id]==0)
                tree[root][id]=++num;
            root=tree[root][id];
        }
        vis[root]++;//单词结尾标记
    }
    
    void build()//构建失配指针
    {
        queue<int>p;
        for(int i=0;i<26;i++)
        {
            if(tree[0][i])//将第二行所有出现过的字母的失配指针指向root节点0
            {
                fail[tree[0][i]]=0;
                p.push(tree[0][i]);
            }
        }
    
        while(!p.empty())
        {
            root=p.front();
            p.pop();
            for(int i=0;i<26;i++)
            {
                if(tree[root][i]==0)//没有建树,不存在这个字母
                    continue;
                p.push(tree[root][i]);
                int fa=fail[root];//fa是父亲节点
                while(fa&&tree[fa][i]==0)//fa不为0,并且fa的子节点没有这个字母
                    fa=fail[fa];//继续判断fa的父亲节点的子节点有没有这个字母
    
                fail[tree[root][i]]=tree[fa][i];//找到就构建失配指针
                
            }
        }
    }
    
    int search(string ss)//查找
    {
        root=0,cnt=0;
        for(int i=0;ss[i];i++)
        {
            id=ss[i]-'a';
            while(root&&tree[root][id]==0)//失配转移
                root=fail[root];
    
            root=tree[root][id];
            int temp=root;
            while(vis[temp])
            {
                cnt=cnt+vis[temp];
                vis[temp]=0;//清除标记,避免重复
                temp=fail[temp];
            }
        }
        return cnt;
    }
    int main()
    {
        cin>>t;
        while(t--)
        {
            memset(tree,0,sizeof(tree));
            memset(vis,0,sizeof(vis));
            cin>>n;
            for(int i=0;i<n;i++)
            {
                cin>>s;
                insert();
            }
            build();
            cin>>ss;//文本串
            cout<<search(ss)<<endl;
        }
    }
  • 相关阅读:
    「字符串算法」第4章 字典树课堂过关
    「字符串算法」第3章 KMP 算法课堂过关
    「字符串算法」第2章 Hash 和 Hash 表课堂过关
    「基础算法」第5章 广度搜索课堂过关
    「基础算法」第3章 二分算法课堂过关
    「基础算法」第1章 递推算法强化训练
    「基础算法」第1章 递推算法课堂过关
    YbtOJ:冲刺 NOIP2020 模拟赛 Day10
    【模板】轻重链剖分
    LINUX-磁盘空间
  • 原文地址:https://www.cnblogs.com/-citywall123/p/11300251.html
Copyright © 2011-2022 走看看