zoukankan      html  css  js  c++  java
  • poj1002 字典树+map+查询单词出现次数

    487-3279

    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 309235   Accepted: 55223

    Description

    Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10. 

    The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

    A, B, and C map to 2 
    D, E, and F map to 3 
    G, H, and I map to 4 
    J, K, and L map to 5 
    M, N, and O map to 6 
    P, R, and S map to 7 
    T, U, and V map to 8 
    W, X, and Y map to 9 

    There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

    Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

    Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

    Input

    The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

    Output

    Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

    No duplicates. 

    Sample Input

    12
    4873279
    ITS-EASY
    888-4567
    3-10-10-10
    888-GLOP
    TUT-GLOP
    967-11-11
    310-GINO
    F101010
    888-1200
    -4-8-7-3-2-7-9-
    487-3279

    Sample Output

    310-1010 2
    487-3279 4
    888-4567 3



    两个map
    #include<iostream>
    #include<algorithm>
    #include<string.h>
    #include<string>
    #include<math.h>
    #include<map>
    #include<set>
    #define ll long long
    using namespace std;
    map<char,char>m;
    map<string,int>mm;
    string s,ss;
    int n;
    int main()
    {
        m['A']='2',m['B']='2',m['C']='2',m['D']='3',m['E']='3';
        m['F']='3',m['G']='4',m['H']='4',m['I']='4',m['J']='5';
        m['K']='5',m['L']='5',m['M']='6',m['N']='6',m['O']='6';
        m['P']='7',m['R']='7',m['S']='7',m['T']='8',m['U']='8';
        m['V']='8',m['W']='9',m['X']='9',m['Y']='9';
        cin>>n;
        while(n--)
        {
            cin>>s;
            int cnt=0;
            for(int i=0;s[i];i++)
            {
                if(s[i]=='-')
                    continue;
                else
                {
                    cnt++;
                    if(m.count(s[i])==0)
                        ss=ss+s[i];
                    else
                        ss=ss+m[s[i]];
                    if(cnt==3)
                        ss=ss+'-';
                }
            }
            mm[ss]++;
            ss.clear();
        }
        int x,flag=0;
        map<string,int>::iterator it;
        for(it=mm.begin();it!=mm.end();it++)
        {
            x=it->second;
            if(x>1)
            {
                cout<<it->first<<' '<<x<<endl;
                flag=1;
            }
        }
        if(flag==0)
            cout<<"No duplicates."<<endl;
        return 0;
    
    }

    字典树

    //poj1002
    #include<iostream>
    #include <map>
    #include <cstdio>
    #include<string.h>
    using namespace std;
    map<char, char> m;
    int id, len, root, pos = 1, k;
    int flag=0;
    int trie[1000005][20], vis[1000005];
    char s[1000000], s1[1000000],str[1000000];
    void insert(char *s1)
    {
    
      root = 0;
      for (int i = 0; i<k; i++)
      {
        int id = s1[i]-'0';
        if (!trie[root][id])
          trie[root][id] = pos++;
        root = trie[root][id];
      }
      vis[root]++;//标记输入一串字符串的最后一个字符,顺便统计每一个单词出现的次数
    
    }
    void dfs(int root, int deep)
    {
      for (int i = 0; i <= 9; i++)
      {
    
        if (trie[root][i])
        {
          str[deep] = i+'0';
          if (vis[trie[root][i]]>=2)
          {
            str[deep + 1] = '';
            for(int j=0;j<3;j++)
              cout<<str[j];
            cout<<'-';
            for(int j=3;j<7;j++)
              cout<<str[j];
            cout << ' ' << vis[trie[root][i]] << endl;
            flag=1;
          }
          dfs(trie[root][i], deep + 1);
        }
    
      }
    
    }
    int main()
    {
      int n;
    
      m['A'] = m['B'] = m['C'] = '2';
      m['D'] = m['E'] = m['F'] = '3';
      m['G'] = m['H'] = m['I'] = '4';
      m['J'] = m['K'] = m['L'] = '5';
      m['M'] = m['N'] = m['O'] = '6';
      m['P'] = m['R'] = m['S'] = '7';
      m['T'] = m['U'] = m['V'] = '8';
      m['W'] = m['X'] = m['Y'] = '9';
    
      while (scanf("%d", &n) != EOF)
      {
        memset(vis, 0, sizeof(vis));
        for (int i = 0; i < n; i++)
        {
          scanf("%s", s);
          len = strlen(s);
          k = 0;
          for (int i = 0; i<len; i++)
          {
            if (s[i] == '-')
              continue;
            else if (s[i] >= 'A'&&s[i] <= 'Y'&&s[i] != 'Q')
            {
              s1[k] = m[s[i]];
              k++;
            }
            else
            {
              s1[k] = s[i];
              k++;
            }
          }
          insert(s1);
        }
        dfs(0, 0);
        if(flag==0)
          cout<<"No duplicates."<<endl;
      }
      return 0;
    }
    等风起的那一天,我已准备好一切
  • 相关阅读:
    Mysql 数据类型
    C++ 11 std::function std::bind使用
    C++ 11 Lambda表达式
    C++ 11 nullptr关键字
    C++ 11 auto关键字
    C++ 11 创建和使用共享 weak_ptr
    C++ 11 创建和使用 unique_ptr
    C++ 11 创建和使用 shared_ptr
    VS15 Visual Assist X破解
    开发人员看测试之细说JBehave
  • 原文地址:https://www.cnblogs.com/-citywall123/p/9500881.html
Copyright © 2011-2022 走看看