zoukankan      html  css  js  c++  java
  • hdu1022 模拟栈

    Train Problem I

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 46887    Accepted Submission(s): 17593


    Problem Description
    As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
     
    Input
    The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
     
    Output
    The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
     
    Sample Input
    3 123 321
    3 123 312
     
    Sample Output
    Yes.
    in
    in
    in
    out
    out
    out
    FINISH
    No.
    FINISH
    Hint
    Hint
    For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
     
     
    栈的应用,就根据栈先进后出的这一特点,依次判断每一个栈顶的元素,看是不是符合给定的出栈顺序
    #include<iostream>
    #include<stack>
    #include<string.h>
    #include<stdio.h>
    using namespace std;
    int main()
    {
      int n;
      char a[10000],b[10000];
      int c[10000];
      while(cin>>n)
      {
        cin>>a;
        cin>>b;
        stack<char>s;
        while(!s.empty())
          s.pop();
       int j=0,num=0;
       s.push(a[0]);
       c[j++]=1;
       for(int i=0;i<n;i++)
       {
        if(s.empty())
          {
            s.push(a[num+1]);
            num++;
            c[j++]=1;
          }
        while(s.top()!=b[i]&&num<n-1)
        {
          s.push(a[num+1]);
          num++;
          c[j++]=1;
        }
        if(s.top()==b[i])
        {
          c[j++]=-1;
          s.pop();
        }
    
       }
        if(s.empty())
        {
          cout<<"Yes."<<endl;
          for(int i=0;i<j;i++)
          {
            if(c[i]==1)
              cout<<"in"<<endl;
            if(c[i]==-1)
              cout<<"out"<<endl;
          }
        }
        else
          cout<<"No."<<endl;
        cout<<"FINISH"<<endl;
      }
    }
    ,按照这个顺序,如果栈顶的符合,则出栈,如果不符合,继续进栈,直到找到符合的(应注意的是,时刻保持栈内有元素,否则访问栈顶的时候会出现,访问越界的错误)
    等风起的那一天,我已准备好一切
  • 相关阅读:
    Python YAML
    Python JASON
    Python正则表达式
    := / ?= /+=
    eclipse的springMVC环境搭建并输出HelloWorld
    SpringMVC简单介绍
    一个简单的MyBatis项目(应用)
    No mapping found for HTTP request with URI [/spring_liu/hello.do] in DispatcherServlet with name 'SpringMVC'
    xml中单词下面有提示下划线
    为什么maven 创建web工程不自动生成Deployment Descriptor:工程名
  • 原文地址:https://www.cnblogs.com/-citywall123/p/9501405.html
Copyright © 2011-2022 走看看