zoukankan      html  css  js  c++  java
  • poj 3273 Monthly Expense (二分)

    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 34725   Accepted: 12983

    Description

    Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

    FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

    FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

    Input

    Line 1: Two space-separated integers: N and M 
    Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

    Output

    Line 1: The smallest possible monthly limit Farmer John can afford to live with.

    Sample Input

    7 5
    100
    400
    300
    100
    500
    101
    400

    Sample Output

    500

    Hint

    If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.
     
    题意:这题目描述的也是没谁了,完全看不懂。好吧,就是将给定的n个数分成k个区间段,取每种分段方法的区间和的最大值加入一个数组A,这个数组A的最小值就是答案。
     
    就是最大化最小值,二分(不懂点这里
     
    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <cstdio>
    using namespace std;
    int n, k;
    int a[100005];
    int go(int m)
    {
        int h = 0, sum = 1;
        for (int i = 1; i <= n; i++)
        {
            if (h + a[i] > m)
            {
                sum++;
                h = a[i];
            }
            else
                h += a[i];
        }
        if (sum>k)
            return 1;
        else
            return 0;
    }
    
    int main()
    {
        int sun = 0;
        int l = 0, r;
        scanf("%d%d", &n, &k);
        for (int i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
            sun += a[i];
            if (l<a[i])
                l = a[i];//确定下界(n个数里面的最大值)
        }
        r = sun;//上界是所有数的和
        int mid;
        while (l<r)
        {
            mid = (l + r) >> 1;
            if (go(mid))
                l = mid + 1;
            else
                r = mid;
        }
        printf("%d", r);
        return 0;
    }
  • 相关阅读:
    Lambda表达式详解
    .net反射详解
    vue插件大全汇总
    DockerToolbox在Win7上的安装和设置
    Ubuntu 16.04 安装 Python3.6
    Azkaban实战,Command类型单一job示例,任务中执行外部shell脚本,Command类型多job工作flow,HDFS操作任务,MapReduce任务,HIVE任务
    Azkaban 使用问题及解决(一)
    Azkaban各种类型的Job编写
    azkaban执行错误 Job failed, Cannot request memory (Xms 0 kb, Xmx 0 kb) from system for job
    window7 修改docker安装的machine 位置
  • 原文地址:https://www.cnblogs.com/-citywall123/p/9518693.html
Copyright © 2011-2022 走看看