zoukankan      html  css  js  c++  java
  • poj2001 Shortest Prefixes(字典树)

    Shortest Prefixes
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 21642   Accepted: 9269

    Description

    A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

    In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

    An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 

    Input

    The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

    Output

    The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

    Sample Input

    carbohydrate
    cart
    carburetor
    caramel
    caribou
    carbonic
    cartilage
    carbon
    carriage
    carton
    car
    carbonate
    

    Sample Output

    carbohydrate carboh
    cart cart
    carburetor carbu
    caramel cara
    caribou cari
    carbonic carboni
    cartilage carti
    carbon carbon
    carriage carr
    carton carto
    car car
    carbonate carbona

    题意:先输出原来输入的字符串,在输出该字符串在字典树上的共有部分再多一个字符
    注意:最后结尾要多输出一个回车

    #include<iostream>
    #include<string>
    #include<string.h>
    using namespace std;
    int tree[40005][26],vis[40005];
    string s[40005];
    int id,root,len,num=0,t=0;
    void insert()
    {
        root=0;
        len=s[t].length();
        for(int i=0;i<len;i++)
        {
            id=s[t][i]-'a';
            if(!tree[root][id])
                tree[root][id]=++num;
            vis[tree[root][id]]++;
            root=tree[root][id];
        }
    }
    
    int search(string ss)
    {
        root=0;
        len=ss.length();
        for(int i=0;i<len;i++)
        {
            id=ss[i]-'a';
            cout<<ss[i];
            if(vis[tree[root][id]]==1)
                break;
            root=tree[root][id];
        }
        return 1;
    }
    int main()
    {
        while(cin>>s[t])
        {
            insert();
            t++;
        }
        for(int i=0;i<t;i++)
        {
            cout<<s[i]<<' ';
            int temp;
            temp=search(s[i]);
            cout<<endl;
        }
        cout<<endl;//多输出一个回车
        return 0;
    }
  • 相关阅读:
    Struts2---配置文件讲解及简单登录示例
    Struts2---环境搭建及包介绍
    Struts2---概述
    Spring---bean的作用域
    Spring---bean的实例化
    Sql Server 2005 .bak备份文进行还原数据库
    Windows Server 2003 R2 With Sp2 序列号
    [Idea]安装avtiviti插件以及 插件中文乱码
    IDEA 跑spring项目找不到get,set的问题
    SpringBoot 集成Avtiviti步骤
  • 原文地址:https://www.cnblogs.com/-citywall123/p/9520113.html
Copyright © 2011-2022 走看看