zoukankan      html  css  js  c++  java
  • 杭电ACM hdu 1398 Square Coins

    Problem Description

    People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
    There are four combinations of coins to pay ten credits: 
    ten 1-credit coins,
    one 4-credit coin and six 1-credit coins,
    two 4-credit coins and two 1-credit coins, and
    one 9-credit coin and one 1-credit coin. 
    Your mission is to count the number of ways to pay a given amount using coins of Silverland.

    Input
    The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

    Output
    For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 

    Sample Input
    2
    10
    30
    0

    Sample Output
    1
    4
    27

    Source
    Asia 1999, Kyoto (Japan)

    Recommend
    Ignatius.L
    原文:https://blog.csdn.net/xiaofei_it/article/details/17041815
    版权声明:本文为博主原创文章,转载请附上博文链接!

    每一种硬币可以无限次使用

    #include <iostream>
    #include <cstring>
    using namespace std;
    #define MAX 301
    int n,a[MAX],b[MAX],i,j,k,v[18];
    int main()
    {
        for (i=1;i<=17;i++)
            v[i]=i*i;
        while ((cin>>n)&&n>0)
        {
            memset(a,0,sizeof(a));
            a[0]=1;
            for (i=1;i<=17;i++)
            {
                memset(b,0,sizeof(b));
                for (j=0;j*v[i]<=n;j++)
                    for (k=0;k+j*v[i]<=n;k++)
                        b[k+j*v[i]]+=a[k];
                memcpy(a,b,sizeof(b));
            }
            cout<<a[n]<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Redis在CentOS和Windows安装过程
    celery在Django中的集成使用
    Celery 框架学习笔记(生产者消费者模式)
    异步任务队列Celery在Django中的使用
    如何使用django+celery+RabbitMQ实现异步执行
    PowerMock+SpringMVC整合并测试Controller层方法
    Python获取指定文件夹下的文件名
    Python中super的应用
    Linux系统(Centos)下安装nodejs并配置环境
    面试题37:序列化二叉树
  • 原文地址:https://www.cnblogs.com/-citywall123/p/9911754.html
Copyright © 2011-2022 走看看