zoukankan      html  css  js  c++  java
  • PAT1008:Elevator

    1008. Elevator (20)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

    Output Specification:

    For each test case, print the total time on a single line.

    Sample Input:
    3 2 3 1
    
    Sample Output:
    41

    思路
    很简单的一道题,判断好楼层的移动方向,计算楼层差值即可。
    代码
    #include<iostream>
    using namespace std;
    int main()
    {
      int N;
      while(cin >> N)
      {
        int cur = 0,next = 0,sum = 0;
        while(N--)
        {
          cin >> next;
          if(next - cur >= 0)
          {
            sum += (next - cur) * 6 + 5;
          }
          else
            sum += (cur - next) * 4 + 5;
          cur = next;
        }
        cout << sum << endl;
      }
    }
  • 相关阅读:
    MFC的奇异non-modality模态对话框
    用于对话框,窗体视图,对话框和属性类型的布局管理器
    在。net中定制OpenFileDialog
    NFS的使用
    snmp-get
    zabbix-trap
    部署
    /etc/rc.local
    gj的交换机在升级了ios之后最新数据不刷新,
    计算型监控项
  • 原文地址:https://www.cnblogs.com/0kk470/p/7622937.html
Copyright © 2011-2022 走看看