zoukankan      html  css  js  c++  java
  • PAT1084:Broken Keyboard

    1084. Broken Keyboard (20)

    时间限制
    200 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

    Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

    Input Specification:

    Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or "_" (representing the space). It is guaranteed that both strings are non-empty.

    Output Specification:

    For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

    Sample Input:
    7_This_is_a_test
    _hs_s_a_es
    
    Sample Output:
    7TI

    思路
    1.set模拟一个字典dic存放键位,队列q按照键位的第一次输入依次存放键,然后根据实际的输入效果确定损坏的键位。
    2.当队列不为空时,依次取出队列的首元素,检查是否在字典中已遍历,没遍历表示缺失,直接打印。
    10.03:map会自动根据键值排序,所以用队列先记录下键位的输入顺序。。。另外这道题20分ac了19分,一个特殊用例死活过不去,暂且先放着。
    11.30:改用set存放值就AC了。

    未AC代码
    #include<iostream>
    #include<map>
    #include<queue>
    using namespace std;
    int main()
    {
        string s;
        string r;
        queue<char> q;
        map<char,int> dic;
        while(cin >> s >> r)
        {
           for(int i = 0;i < s.size();i++)
           {
               if(s[i] == '_' || dic.count(toupper(s[i])) > 0)
                 continue;
               else
               {
                 dic.insert(pair<char,int>(toupper(s[i]),1));
                 q.push(toupper(s[i]));
               }
           }
    
           for(int i = 0;i < r.size();i++)
           {
               if(r[i] == '_')
                continue;
               else
               {
                 dic[toupper(r[i])] = -1;
               }
           }
    
           while(!q.empty())
           {
               if(dic[q.front()] > 0)
                 cout << q.front();
               q.pop();
           }
           cout << endl;
        }
    }

     AC代码

    #include<iostream>
    #include<set>
    #include<queue>
    using namespace std;
    int main()
    {
        string s;
        string r;
        queue<char> q;
        set<char> dic;
        while(cin >> s >> r)
        {
           for(int i = 0;i < s.size();i++)
           {
               if(dic.find(toupper(s[i])) == dic.end())
               {
                 dic.insert(toupper(s[i]));
                 q.push(toupper(s[i]));
               }
           }
    
           for(int i = 0;i < r.size();i++)
           {
               if(dic.find(toupper(r[i])) != dic.end())
               {
                 dic.erase(toupper(r[i]));
               }
           }
    
           while(!q.empty())
           {
               if(dic.find(q.front()) != dic.end())
                 cout << q.front();
               q.pop();
           }
        }
    }
    

      

     
  • 相关阅读:
    array_count_values源码
    php 编译安装记录
    mysql 安装的过程做个记录
    初识highcharts 库
    php 不重新编译增加新扩展的方法
    备考PMP
    Beyond Compare4破解--写reg脚本删除注册表
    SourceTree 跳过登录
    正则 (?=exp)
    springmvc--处理器的返回参数
  • 原文地址:https://www.cnblogs.com/0kk470/p/7623868.html
Copyright © 2011-2022 走看看