zoukankan      html  css  js  c++  java
  • PAT1120: Friend Numbers

    1120. Friend Numbers (20)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different friend ID's among them. Note: a number is considered a friend of itself.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 104.

    Output Specification:

    For each case, print in the first line the number of different frind ID's among the given integers. Then in the second line, output the friend ID's in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

    Sample Input:
    8
    123 899 51 998 27 33 36 12
    
    Sample Output:
    4
    3 6 9 26

    思路

    水题,用个map记录数字的每一位数相加的和就行,map自动升序排序,所以直接遍历map输出就行。

    代码
    #include<iostream>
    #include<map>
    #include<iterator>
    using namespace std;
    
    int main()
    {
       int N;
       while(cin >> N)
       {
           map<int,int> dic;
           for(int i = 0;i < N;i++)
           {
               int number,sum = 0;
               cin >> number;
               while(number != 0)
               {
                   sum += (number % 10);
                   number /= 10;
               }
               dic.insert(pair<int,int>(sum,1));
           }
    
           cout << dic.size() << endl;
           map<int,int>::iterator it = dic.begin();
           cout << it++->first;
           for(; it != dic.end();it++ )
           {
               cout << " " << it->first;
           }
           cout << endl;
       }
    }
  • 相关阅读:
    bzoj 1030 [JSOI2007]文本生成器
    Swift 学习笔记 (闭包)
    Swift 学习笔记 (函数)
    HTML 学习笔记 JQueryUI(Interactions,Widgets)
    HTML 学习笔记 JQuery(表单,表格 操作)
    HTML 学习笔记 JQuery(animation)
    HTML 学习笔记 JQuery(盒子操作)
    HTML 学习笔记 JQuery(事件)
    HTML 学习笔记 JQuery(DOM 操作3)
    HTML 学习笔记 JQuery(DOM 操作2)
  • 原文地址:https://www.cnblogs.com/0kk470/p/7631839.html
Copyright © 2011-2022 走看看