zoukankan      html  css  js  c++  java
  • PAT1125:Chain the Ropes

    1125. Chain the Ropes (25)

    时间限制
    200 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

    Your job is to make the longest possible rope out of N given segments.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (2 <= N <= 104). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104.

    Output Specification:

    For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

    Sample Input:
    8
    10 15 12 3 4 13 1 15
    
    Sample Output:
    14

    思路

    可以用哈夫曼树的思路(其实本质就是一个贪婪算法):优先选两个最小的绳子合成新的绳子,然后循环即可。
    所以为了得到最长的绳子,那么只需要对输入数据升序排下序即可。

    代码
    #include<iostream>
    #include<vector>
    #include<algorithm>
    using namespace std;
    int main()
    {
      int N;
      while(cin >> N)
      {
       vector<int> ropes(N);
       for(int i = 0;i < N;i++)
       {
          cin >> ropes[i];
       }
       sort(ropes.begin(),ropes.end());
       int length = 0;
       for(int i = 0;i < N ;i++)
       {
          if(i == 0)
          {
            length = ropes[i];
            continue;
          }
          length = (length + ropes[i])/2;
       }
       cout << length << endl;
      }
    }
  • 相关阅读:
    Ios插件开发
    React-Native学习指南
    APP测试基本流程
    iOS开发-由浅至深学习block
    你真的会用UITableView嘛
    iOS系统右滑返回全局控制方案
    优化UITableViewCell高度计算的那些事
    UITableViewCell高度自适应探索--AutoLayout结合Frame
    UITableView优化技巧
    页面间跳转的性能优化(一)
  • 原文地址:https://www.cnblogs.com/0kk470/p/7642984.html
Copyright © 2011-2022 走看看