zoukankan      html  css  js  c++  java
  • PAT1124:Raffle for Weibo Followers

    1124. Raffle for Weibo Followers (20)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives three positive integers M (<= 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

    Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

    Output Specification:

    For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print "Keep going..." instead.

    Sample Input 1:
    9 3 2
    Imgonnawin!
    PickMe
    PickMeMeMeee
    LookHere
    Imgonnawin!
    TryAgainAgain
    TryAgainAgain
    Imgonnawin!
    TryAgainAgain
    
    Sample Output 1:
    PickMe
    Imgonnawin!
    TryAgainAgain
    
    Sample Input 2:
    2 3 5
    Imgonnawin!
    PickMe
    
    Sample Output 2:
    Keep going...

    思路

    1.map模拟一个字典dic记录该用户是否领过奖。
    2.用一个bool值hasWinner来标记是否有人获过奖。

    代码
    #include<iostream>
    #include<vector>
    #include<map>
    using namespace std;
    int main()
    {
        int M,N,S;
        while(cin >> M >> N >> S)
        {
           vector<string> List(M + 1);
           map<string,int> dic;
           bool hasWinner = false;
           for(int i = 1;i <= M;i++)
           {
               cin >> List[i];
           }
    
           for(int i = S;i <= M;i += N)
           {
               while(dic.count(List[i]) > 0 && i <= M) i++;
               if(i > M) break;
               hasWinner = true;
               cout << List[i] << endl;
               dic[List[i]]++;
           }
           if(!hasWinner)
              cout << "Keep going..." << endl;
        }
    }
  • 相关阅读:
    概念
    Jquery和Aspnet前台控件及后台代码交互
    未能找到引用的组件“Microsoft.Office.Core
    C#操作Excel,调用ApplicationClass.Quit()关闭Excel时,发生异常:Microsoft Office Word 遇到问题需要关闭
    Javasrcipt捕获按键
    使用Interop.Excel生成Excel
    Javasrcipt时间相关函数
    (转)各种纹理贴图技术
    (转)立体纹理
    (转)地形碰撞高度计算
  • 原文地址:https://www.cnblogs.com/0kk470/p/7739808.html
Copyright © 2011-2022 走看看