zoukankan      html  css  js  c++  java
  • PAT1004:Counting Leaves

    1004. Counting Leaves (30)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue
    A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

    Input

    Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

    ID K ID[1] ID[2] ... ID[K]
    
    where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

    Output

    For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

    The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

    Sample Input
    2 1
    01 1 02
    
    Sample Output
    0 1

    思路

    简单题,主要考察树的层次遍历。
    用一个邻接表来构建树然后bfs就行了,bfs时插入一个label区分树的层级,然后统计叶子节点就行。

    代码
    #include<vector>
    #include<iostream>
    #include<queue>
    using namespace std;
    vector<vector<int>> tree(100);
    vector<int> levels;
    vector<bool> isroot(100,true);
    const int label = -2;
    
    void bfs(const int& root)
    {
        queue<int> q;
        q.push(root);
        q.push(label);
        int countleaves = 0;
        while(!q.empty())
        {
            int tmp = q.front();
            q.pop();
            if(tmp == label)
            {
                levels.push_back(countleaves);
                countleaves = 0;
                if(!q.empty())
                  q.push(label);
                continue;
            }
            if(tree[tmp].empty())
                countleaves++;
            else
            {
                for(int i = 0;i < tree[tmp].size();i++)
                {
                    q.push(tree[tmp][i]);
                }
            }
        }
    }
    
    int main()
    {
       int N,M;
       while(cin >> N >> M)
       {
          for(int i = 1;i <= M;i++)
          {
              int cur,K;
              cin >> cur >> K;
              for(int j = 0;j < K;j++)
              {
                  int tmp;
                  cin >> tmp;
                  isroot[tmp] = false;
                  tree[cur].push_back(tmp);
              }
          }
    
          int root = -1;
          for(int i = 1;i <= N;i++)
          {
              if(isroot[i])
              {
                  root = i;
                  break;
              }
          }
          bfs(root);
    
          cout << levels[0];
          for(int i = 1;i < levels.size();i++)
            cout << " " << levels[i];
          cout << endl;
       }
    }
    

      

  • 相关阅读:
    C#数组添加元素
    C#数组排序方法
    C#遍历数组
    C#动态数组ArrayList
    C#传递数组参数
    基础题(四)
    基础题(三)
    CMDB概述(二)
    CMDB概述(一)
    Django(基础篇)
  • 原文地址:https://www.cnblogs.com/0kk470/p/7760948.html
Copyright © 2011-2022 走看看