zoukankan      html  css  js  c++  java
  • PAT1019:General Palindromic Number

    1019. General Palindromic Number (20)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

    Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

    Input Specification:

    Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

    Output Specification:

    For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "ak ak-1 ... a0". Notice that there must be no extra space at the end of output.

    Sample Input 1:
    27 2
    
    Sample Output 1:
    Yes
    1 1 0 1 1
    
    Sample Input 2:
    121 5
    
    Sample Output 2:
    No
    4 4 1
    

    思路

    进制转换题,检验一个十进制数字用b进制数表示的时候是否是一个回文数。用一个数组保存b进制每一位的数字,然后检查是否对称就行。

    代码

    #include<iostream>
    #include<vector>
    using namespace std;
    vector<int> digits(30);
    int main()
    {
        int N,b;
        while(cin >> N >> b)
        {
            int index = 0;
            while( N != 0)
            {
                digits[index++] = N % b;
                N = N/b;
            }
            bool isPal = true;
            for(int i = 0;i < index/2;i++)
            {
                if(digits[i] != digits[index - i - 1])
                {
                    isPal = false;
                    break;
                }
            }
            if(isPal)
                cout << "Yes" <<endl;
            else
                cout << "No" << endl;
            for(int i = index - 1;i >= 0;i--)
            {
                cout << digits[i];
                if( i != 0)
                    cout << " ";
            }
            if(index == 0 )
                cout << 0;
            cout << endl;
        }
    }
    

      

  • 相关阅读:
    C#实现简单的委托异步调用
    jquery each遍历节点使用
    js操作document文档元素 节点交换交换
    js闭包使用
    .net下各个数据类型所占用的字节
    html file控件选择文件后立即预览 js实现
    叉积运用-判断凸多边形
    高精度算法-大数加法
    Dfs学习经验(纸上运行理解DFS)【两道题】
    a标签点击后更改颜色
  • 原文地址:https://www.cnblogs.com/0kk470/p/7774703.html
Copyright © 2011-2022 走看看