zoukankan      html  css  js  c++  java
  • PAT1077: Kuchiguse

    1077. Kuchiguse (20)

    时间限制
    100 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    HOU, Qiming

    The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

    • Itai nyan~ (It hurts, nyan~)
    • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

    Now given a few lines spoken by the same character, can you find her Kuchiguse?

    Input Specification:

    Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

    Output Specification:

    For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write "nai".

    Sample Input 1:
    3
    Itai nyan~
    Ninjin wa iyadanyan~
    uhhh nyan~
    
    Sample Output 1:
    nyan~
    
    Sample Input 2:
    3
    Itai!
    Ninjinnwaiyada T_T
    T_T
    
    Sample Output 2:
    nai

    思路

    求输入的几个字符串的最长公共后缀。
    用一个cmstr暂时记录最长公共后缀,然后对于每一个输入的新字符串循环比较更新就行。

    代码
    #include<iostream>
    using namespace std;
    int main()
    {
        int N;
        cin >> N;
        string cmstr;
        getchar();
        for(int i = 0; i < N; i++)
        {
            string s;
            getline(cin,s);
            const int len = s.size();
            for(int j = 0; j < len/2; j++)
            {
                swap(s[j],s[len - j - 1]);
            }
            if(i == 0)
            {
                cmstr = s;
                continue;
            }
            else
            {
                int minlen = len > cmstr.size()?cmstr.size():len;
                for(int v = 0; v < minlen; v++)
                {
                    if(cmstr[v] != s[v])
                    {
                        cmstr = cmstr.substr(0,v);
                        break;
                    }
                }
            }
    
        }
        if(cmstr.size() == 0)
            cout << "nai" <<endl;
        else
        {
            for(int i = cmstr.size() - 1;i >= 0;i--)
            {
                cout << cmstr[i];
            }
        }
    }
    

      

  • 相关阅读:
    最后一周作业
    第十四,十五周作业
    第七周作业
    第六周作业
    第四周作业
    第三周作业
    第二周作业
    二学期第三次作业
    二学期第二次作业
    二学期第一次作业
  • 原文地址:https://www.cnblogs.com/0kk470/p/7775021.html
Copyright © 2011-2022 走看看