zoukankan      html  css  js  c++  java
  • PAT1127:ZigZagging on a Tree

    1127. ZigZagging on a Tree (30)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

    Sample Input:
    8
    12 11 20 17 1 15 8 5
    12 20 17 11 15 8 5 1
    
    Sample Output:
    1 11 5 8 17 12 20 15

    思路

    类似Pat1029,根据中序遍历和后序遍历序列确定树,以层次遍历的形式存入vector<vector<int>>中,然后按每一层往返输出就行。

    代码
    #include<iostream>
    #include<vector>
    #include<queue>
    using namespace std;
    vector<int> postorder(31);
    vector<int> inorder(31);
    vector<vector<int>> levels(31);
    
    
    void buildTree(const int pl,const int pr,const int il,const int ir,const int level)
    {
    
        if(pl > pr || il > ir)
            return;
        int root = postorder[pr],i = 0;
        while( inorder[il + i ] !=  root) i++;
        levels[level].push_back(root);
        buildTree(pl,pl + i - 1,il,il + i - 1,level + 1);
        buildTree(pl + i ,pr - 1,il + i + 1,ir,level + 1);
    }
    
    
    void zigzag()
    {
        cout << levels[0][0];
        bool zigzag = false;
        for(int i = 1; i < levels.size() && !levels[i].empty();i++)
        {
            if(zigzag)
            {
                for(int j = levels[i].size() - 1;j >= 0;j--)
                {
                    cout << " " << levels[i][j];
                }
            }
            else
            {
               for(int j = 0;j < levels[i].size();j++)
               {
                   cout << " " << levels[i][j];
               }
            }
            zigzag = !zigzag;
        }
    }
    
    
    int main()
    {
        int N;
        while(cin >> N)
        {
           for(int i = 0;i < N;i++)
             cin >> inorder[i];
           for(int i = 0;i < N;i++)
             cin >> postorder[i];
           buildTree(0,N - 1,0, N - 1,0);
           zigzag();
        }
    }
    

      

  • 相关阅读:
    自定义UINavigationBar
    UIImage 拉伸图片 resizableImageWithCapInsets
    自定义UINavigationBar上面的按钮
    tableView中deselectRowAtIndexPath的作用
    [LeetCode] Search a 2D Matrix, Solution
    [LeetCode] Longest Valid Parentheses, Solution
    我也写了一个牛顿迭代法,貌似不需要特殊处理溢出的情况 class Solution { public...
    [LeetCode] Remove Duplicates from Sorted List II, Solution
    [LeetCode] Palindrome Partitioning, Solution
    [LeetCode] Two Sum, Solution
  • 原文地址:https://www.cnblogs.com/0kk470/p/7886435.html
Copyright © 2011-2022 走看看