zoukankan      html  css  js  c++  java
  • PAT1035: Password

    1035. Password (20)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

    Output Specification:

    For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line "There are N accounts and no account is modified" where N is the total number of accounts. However, if N is one, you must print "There is 1 account and no account is modified" instead.

    Sample Input 1:

    3
    Team000002 Rlsp0dfa
    Team000003 perfectpwd
    Team000001 R1spOdfa
    
    Sample Output 1:
    2
    Team000002 RLsp%dfa
    Team000001 R@spodfa
    
    Sample Input 2:
    1
    team110 abcdefg332
    
    Sample Output 2:
    There is 1 account and no account is modified
    
    Sample Input 3:
    2
    team110 abcdefg222
    team220 abcdefg333
    
    Sample Output 3:
    There are 2 accounts and no account is modified

    思路
    水题,记录修改纠正过的密码就行。
    代码
    #include<iostream>
    #include<vector>
    using namespace std;
    struct user
    {
        string id;
        string password;
    };
    int main()
    {
        int N;
        while(cin >> N)
        {
           vector<user> dic;
           for(int i = 0;i < N;i++)
           {
              user tmp;
              cin >> tmp.id >> tmp.password;
              bool isModified = false;
              for(int j = 0; j < tmp.password.size();j++)
              {
                  if(tmp.password[j] == '1')
                  {
                      tmp.password[j] = '@';
                      isModified = true;
                  }
                  else if(tmp.password[j] == '0')
                  {
                      tmp.password[j] = '%';
                      isModified = true;
                  }
                  else if(tmp.password[j] == 'l')
                  {
                      tmp.password[j] = 'L';
                      isModified = true;
                  }
                  else if(tmp.password[j] == 'O')
                  {
                      tmp.password[j] = 'o';
                      isModified = true;
                  }
              }
              if(isModified)
              {
                  dic.push_back(tmp);
              }
           }
           if(dic.empty())
           {
               if( N == 1)
                cout << "There is 1 account and no account is modified";
               else
                cout << "There are " << N <<" accounts and no account is modified";
           }
           else
           {
               cout << dic.size() << endl;
               for(int i = 0;i < dic.size();i++)
               {
                  cout << dic[i].id << " " << dic[i].password << endl;
               }
           }
        }
    }
    

      

  • 相关阅读:
    vs2012远程调试功能的改进
    【转】SpringBoot处理url中的参数的注解
    通过Maven导出war包时报错:Failed to execute goal org.apache.maven.plugins:maven-war-plugin:2.2:war (default-war) on project
    【转载】JAVA生成随机数工具类RandomStringUtils详解
    linux centos7 搭建开发环境
    【转载】idea 使用Tomcat 部署war 和 war exploded的区别
    SSM整合文件
    mybatis 数据库properties
    win10 在服务中找不到mysql的解决办法
    idea 创建springmvc项目
  • 原文地址:https://www.cnblogs.com/0kk470/p/7929755.html
Copyright © 2011-2022 走看看