zoukankan      html  css  js  c++  java
  • PAT1043:Is It a Binary Search Tree

    1043. Is It a Binary Search Tree (25)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

    • The left subtree of a node contains only nodes with keys less than the node's key.
    • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
    • Both the left and right subtrees must also be binary search trees.

    If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

    Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input 1:
    7
    8 6 5 7 10 8 11
    
    Sample Output 1:
    YES
    5 7 6 8 11 10 8
    
    Sample Input 2:
    7
    8 10 11 8 6 7 5
    
    Sample Output 2:
    YES
    11 8 10 7 5 6 8
    
    Sample Input 3:
    7
    8 6 8 5 10 9 11
    
    Sample Output 3:
    NO

    思路
    判断一个序列是不是一个二叉搜索树或者其镜像的前序遍历序列。是的话输出对应的后序遍历序列。
    1.对于一棵树来说,依次找到左子树末尾的节点和右子树开始节点,然后后续遍历的形式将根节点推入一个新序列中
    2.对左右子树重复1的操作。
    3.如果新序列的长度就为总结点数N,那么该序列就为后序遍历序列。
    4.如果不为N,以镜像的结构再重复1.2的操作,如果为N仍满足要求,否则输出NO。
    代码
    #include<iostream>
    #include<vector>
    using namespace std;
    vector<int> preorder;
    vector<int> postorder;
    
    void preTopost(int start,int des,bool mirror)
    {
        if(start > des)
            return;
        int left = start + 1,right = des;
    
        if(!mirror)
        {
            while(left <= des && preorder[start] > preorder[left]) left++;
            while(right > start && preorder[start] <= preorder[right]) right--;
        }
        else
        {
            while(left <= des && preorder[start] <= preorder[left]) left++;
            while(right > start && preorder[start] > preorder[right]) right--;
        }
    
        if(left - right != 1)
            return;
        preTopost(start + 1,right,mirror); //right为左子树的最后一个节点
        preTopost(left,des,mirror);  //left为右子树的根节点
        postorder.push_back(preorder[start]);
    }
    
    int main()
    {
        int N;
        while(cin >> N)
        {
            for(int i = 0;i < N;i++)
            {
                int tmp;
                cin >> tmp;
                preorder.push_back(tmp);
            }
            bool mirror = false;
            preTopost(0,N - 1,mirror);
            if(postorder.size() != N)
            {
                postorder.clear();
                preTopost(0,N - 1,!mirror);
            }
            if(postorder.size() != N)
                cout << "NO" << endl;
            else
            {
                cout << "YES" << endl;
                for(int i = 0;i < N;i++)
                {
                    if(i != 0)
                        cout << " ";
                    cout << postorder[i];
                }
            }
            postorder.clear();
        }
    }
    

      

  • 相关阅读:
    字符串
    完全背包
    背包2
    0-1背包
    生日劲歌会
    设计照明系统
    宝岛探险
    汉诺塔问题
    并查集 黑帮危机
    数塔问题
  • 原文地址:https://www.cnblogs.com/0kk470/p/8004882.html
Copyright © 2011-2022 走看看