zoukankan      html  css  js  c++  java
  • PAT1079 :Total Sales of Supply Chain

    1079. Total Sales of Supply Chain (25)

    时间限制
    250 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

    Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

    Now given a supply chain, you are supposed to tell the total sales from all the retailers.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

    Ki ID[1] ID[2] ... ID[Ki]

    where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

    Sample Input:
    10 1.80 1.00
    3 2 3 5
    1 9
    1 4
    1 7
    0 7
    2 6 1
    1 8
    0 9
    0 4
    0 3
    
    Sample Output:
    42.4

    思路
    简单的dfs问题,每次到达叶节点加上对应的总价就行
    代码
    #include<iostream>
    #include<vector>
    #include<iomanip>
    using namespace std;
    vector<vector<int>> graph(100001);
    vector<int> amount(100001);
    double price,rate,total = 0;
    
    
    void dfs(int root,double curprice,int level)
    {
        if(level != 0)
          curprice *= (1.0 + rate);
        if(amount[root] > 0)
        {
           total += curprice * amount[root];
        }
        else
        {
            for(int i = 0;i < graph[root].size();i++)
                dfs(graph[root][i],curprice,level + 1);
        }
    }
    
    int main()
    {
       int N;
       while(cin >> N >> price >> rate)
       {
           rate /= 100.0;
           for(int i = 0;i < N;i++)
           {
             int k;
             cin >> k;
             if(k == 0)
                 cin >> amount[i];
             else
             {
                 for(int j = 0;j < k;j++)
                 {
                     int tmp;
                     cin >> tmp;
                     graph[i].push_back(tmp);
                 }
             }
           }
           dfs(0,price,0);
           cout << fixed << setprecision(1) << total << endl;
       }
    }
    

      

  • 相关阅读:
    PHP7.X 安装mysql扩展
    雷军说云计算是下一个风口
    玩转超级列表框4 拖放组建的使用。
    玩转超级列表框第三课的自编代码
    易语言核心支持库 文本操作与文件读写
    插入表项的标题和置标题的标题的区别
    精易模块8.2 类_超级列表框 外部超级列表框的区别和使用注意点
    如何理解动态规划
    雷军:互联网思维本质上就是群众路线
    纯互联网项目“失宠”乐博资本杨宁称今后只投O2O
  • 原文地址:https://www.cnblogs.com/0kk470/p/8004890.html
Copyright © 2011-2022 走看看