zoukankan      html  css  js  c++  java
  • PAT1106:Lowest Price in Supply Chain

    1106. Lowest Price in Supply Chain (25)

    时间限制
    200 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

    Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

    Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

    Input Specification:

    Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

    Ki ID[1] ID[2] ... ID[Ki]

    where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1010.

    Sample Input:
    10 1.80 1.00
    3 2 3 5
    1 9
    1 4
    1 7
    0
    2 6 1
    1 8
    0
    0
    0
    
    Sample Output:
    1.8362 2

    思路
    类似 pat1079 的问题,bfs找到最长的路径然后计算价格就行。
    代码
    #include<iostream>
    #include<vector>
    #include<queue>
    #include<iomanip>
    using namespace std;
    vector<vector<int>> graph(100000);
    vector<bool> visits(100000,false);
    /*
    1.输入,构图
    2.bfs找最短
    3.迭代求乘积
    */
    
    
    int bfs(int& cnt)
    {
       queue<int> q;
       int minnum = 233333,level = 1,label = -1;
       q.push(0);q.push(label);
       while(!q.empty())
       {
         int tmp = q.front();
         q.pop();
         if(tmp == label)
         {
             if(q.empty())
                break;
             else
             {
                 level++;
                 q.push(label);
                 continue;
             }
         }
         visits[tmp] = true;
         if(graph[tmp].empty())
         {
             if(minnum > level)
             {
                 minnum = level;
                 cnt = 1;
             }
             else if (minnum == level)
             {
                 cnt++;
             }
         }
         else
         {
             for(int i = 0;i < graph[tmp].size();i++)
             {
                 if(!visits[graph[tmp][i]])
                    q.push(graph[tmp][i]);
             }
         }
       }
       return minnum - 1;
    }
    
    int main()
    {
        int n;
        double p,r;
        while(cin >> n >> p >> r)
        {
            r /= 100;
            for(int i = 0;i < n;i++)
            {
                int num;
                cin >> num;
                if(num == 0)
                    continue;
                for(int j = 0;j < num;j++)
                {
                    int tmp;
                    cin >> tmp;
                    graph[i].push_back(tmp);
                }
            }
            int cnt = 0;
            int len = bfs(cnt);
            for(int i = 0;i < len;i++)
            {
                p *= static_cast<double>(1 + r);
            }
            cout << fixed << setprecision(4) << p << " " << cnt << endl;
        }
    }
    

      

  • 相关阅读:
    Best Practices for Background Jobs_3 Managing Device Awake State之电源锁、Alarm、WakefulBroadcastReceiver
    一种扩大View点击范围的方法
    IntentService
    DNS
    GPU硬件加速相关
    SOA 面向服务的体系结构
    android APK 文件的生成过程
    PHP简介
    代码安装apk文件
    View 的 focus 和 selected 状态, TabContainer实现
  • 原文地址:https://www.cnblogs.com/0kk470/p/8004897.html
Copyright © 2011-2022 走看看