zoukankan      html  css  js  c++  java
  • bzoj 2276: [Poi2011]Temperature

    2276: [Poi2011]Temperature

    Time Limit: 20 Sec  Memory Limit: 32 MB
    Submit: 749  Solved: 344
    [Submit][Status][Discuss]

    Description

    The Byteotian Institute of Meteorology (BIM) measures the air temperature daily. The measurement is done automatically, and its result immediately printed. Unfortunately, the ink in the printer has long dried out... The employees of BIM however realised the fact only recently, when the Byteotian Organisation for Meteorology (BOM) requested access to that data.

    An eager intern by the name of Byteasar saved the day, as he systematically noted down the temperatures reported by two domestic alcohol thermometers placed on the north and south outside wall of the BIM building. It was established decades ago by various BIM employees that the temperature reported by the thermometer on the south wall of the building is never lower than the actual temperature, while that reported by the thermometer on the north wall of the building is never higher than the actual temperature. Thus even though the exact temperatures for each day remain somewhat of a mystery, the range they were in is known at least.

    Fortunately for everyone involved (except Byteasar and you, perhaps), BOM does not require exact temperatures. They only want to know the longest period in which the temperature was not dropping (i.e. on each successive day it was no smaller than on the day before). In fact, the veteran head of BIM knows very well that BOM would like this period as long as possible. To whitewash the negligence he insists that Byteasar determines, based on his valuable notes, the longest period in which the temperature could have been not dropping. Now this is a task that Byteasar did not quite expect on his BIM internship, and he honestly has no idea how to tackle it. He asks you for help in writing a program that determines the longest such period.

    某国进行了连续n天的温度测量,测量存在误差,测量结果是第i天温度在[l_i,r_i]范围内。
    求最长的连续的一段,满足该段内可能温度不降。

    Input

    In the first line of the standard input there is one integer n(1<=N<=1000000) that denotes the number of days for which Byteasar took notes on the temperature. The measurements from day are given in the line no.i+1 Each of those lines holds two integers, x and y (-10^9<=x<=y<=10^9). These denote, respectively, the minimum and maximum possible temperature on that particular day, as reported by the two thermometers.

    In some of the tests, worth 50 points in total, the temperatures never drop below -50 degrees (Celsius, in case you wonder!) and never exceeds 50 degrees (-50<=x<=y<=50)  

    第一行n
    下面n行,每行l_i,r_i
    1<=n<=1000000

    Output

    In the first and only line of the standard output your program should print a single integer, namely the maximum number of days for which the temperature in Byteotia could have been not dropping.

    一行,表示该段的长度

    Sample Input

    6

    6 10

    1 5

    4 8

    2 5

    6 8

    3 5

    Sample Output

    4
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    const int N=1000010;
    int a[N],b[N],q[N],f[N];
    int main()
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)scanf("%d %d",&a[i],&b[i]);
        int tail=0,head=1,ans=0;
        f[0]=1;
        for(int i=1;i<=n;i++)
        {
            while(tail>=head&&a[q[tail]]<=a[i]) tail--;
            q[++tail]=i;
            f[i]=f[i-1];
            while(a[q[head]]>b[i]) f[i]=q[head++]+1;
        }
        for(int i=1;i<=n;i++) ans=max(ans,i-f[i]+1);
        printf("%d",ans);
        return 0;
    }
    View Code

    单调队列!!!

    difficult.

  • 相关阅读:
    jquery index与eq
    尝试一下
    document
    2017-03-28 java script DOM操作
    2017-03-25 CSS 样式
    CSS 样式表分类
    CSS 样式表
    HTML 框架
    表格
    HTML常用标记
  • 原文地址:https://www.cnblogs.com/12fs/p/7545261.html
Copyright © 2011-2022 走看看