zoukankan      html  css  js  c++  java
  • HDU2088JAVA2

    Box of Bricks

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 14836    Accepted Submission(s): 4912


    Problem Description
    Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I've built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height. Then you would have a real wall.”, she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?
     
    Input
    The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1≤n≤50 and 1≤hi≤100.

    The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

    The input is terminated by a set starting with n = 0. This set should not be processed.
     
    Output
    For each set, print the minimum number of bricks that have to be moved in order to make all the stacks the same height.
    Output a blank line between each set.
     
    Sample Input
    6
    5 2 4 1 7 5
    0
     
    Sample Output
    5

    import java.util.Scanner;
    public class Main2088 {
    public static void main(String[] args) {
    Scanner cin=new Scanner(System.in);
    int flag=0;
    while(cin.hasNext()){
    int n=cin.nextInt();
    if(n==0)
    break;
    if(flag==1)
    System.out.println();
    int []a=new int [n];
    int sum=0;
    for(int i=0;i<n;i++){
    a[i]=cin.nextInt();
    sum+=a[i];
    }
    sum=sum/n;
    int s=0;
    for(int i=0;i<n;i++){
    if(a[i]>sum){
    s+=(a[i]-sum);
    }
    }
    System.out.println(s);
    flag=1;

    }
    }

    }

    这是一个水题,注意一下格式的输出就行。

  • 相关阅读:
    WPF 关于多语言 的实现 学习,利用反射中的特性
    WPF Textbox 中文输入崩溃 规避
    自定义控件.依赖项属性同步更新内部控件属性
    HexInput
    HashMap实现原理分析
    centos下nginx安装
    dos下mybatis自动生成代码
    设计模式之装饰器模式
    Java 中的悲观锁和乐观锁的实现
    redis分布式锁
  • 原文地址:https://www.cnblogs.com/1314wamm/p/5558156.html
Copyright © 2011-2022 走看看