zoukankan      html  css  js  c++  java
  • hdu1047(Java)大数相加

    题目大意:输入n组数据,每组数据中又有若干长度不大于100的整数,以0结束每组数据的输入,求每组中数据之和。每两组数据输入之间有一行空格,输出也是如此。

    Integer Inquiry

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 17770 Accepted Submission(s): 4628


    Problem Description
    One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
    ``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)
     
    Input
    The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

    The final input line will contain a single zero on a line by itself.
     
    Output
    Your program should output the sum of the VeryLongIntegers given in the input.


    This problem contains multiple test cases!

    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

    The output format consists of N output blocks. There is a blank line between output blocks.
     
    Sample Input
    1
    123456789012345678901234567890
     
    123456789012345678901234567890
     
    123456789012345678901234567890 0
     
    Sample Output
    370370367037037036703703703670
    --------------------------------------------------

    import java.math.BigDecimal;
    import java.math.BigInteger;
    import java.util.Scanner;
    public class Main1047 {
    public static void main(String[] args) {
    Scanner cin=new Scanner(System.in);
    while(cin.hasNext()){
    int n=cin.nextInt();
    Object obj=BigInteger.ZERO;
    for(int i=0;i<n;i++){
    BigInteger sum=BigInteger.ZERO;
    while(true){
    BigInteger b=cin.nextBigInteger();
    if(b.equals(obj)){//这里也可以用commparTo(BigInteger.ZERO)==0进行判断;
    System.out.println(sum);
    if(i!=n-1)
    System.out.println();
    break;
    }
    sum=sum.add(b);
    }
    }
    }
    }
    }

     
  • 相关阅读:
    成功的速度一定要大于父母老去的速度
    luogg_java学习_09_泛型_集合
    luogg_java学习_08_设计模式_API
    luogg_java学习_07_抽象类_接口_多态学习总结
    报表请求默认输出格式(html或者excel)设置
    XML报表开发基本过程
    rtf模板常用技巧
    xml模板提交请求submit_request
    XML基础知识
    HTML语言常用语法
  • 原文地址:https://www.cnblogs.com/1314wamm/p/5682018.html
Copyright © 2011-2022 走看看