zoukankan      html  css  js  c++  java
  • poj1611(感染病患者)

    The Suspects
    Time Limit: 1000MS   Memory Limit: 20000K
    Total Submissions: 24587   Accepted: 12046

    Description

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
    Once a member in a group is a suspect, all members in the group are suspects.
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

    Input

    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

    Output

    For each case, output the number of suspects in one line.

    Sample Input

    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0

    Sample Output

    4
    1
    1













    #include<stdio.h>
    #include<string.h>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int m,n;
    int a[30005];
    int b[30005];
    int pd[30005];
    void  update()
    {
        for(int i=0; i<n; i++)
            a[i]=i;
    }
    int get(int  x)
    {
        if(a[x]!=x)
            a[x]=get(a[x]);
        return a[x];
    }
    void unin(int x,int y)
    {
        a[get(y)]=get(x);
    }
    int main()
    {


        while(scanf("%d%d",&n,&m)!=EOF)
        {
            if(n==0&&m==0)
                break;
            memset(b,0,sizeof(b));
            memset(pd,0,sizeof(pd));
            memset(a,0,sizeof(a));
            update();
            for(int i=1; i<=m; i++)
            {
                int ans;
                scanf("%d",&ans);
                for(int j=1; j<=ans; j++)
                {

                    scanf("%d",&b[j]);
                    if(pd[b[j]]==0)
                        pd[b[j]]=1;
                    if(j!=1)
                        unin(b[j-1],b[j]);
                }
            }
            int sum=0;
            if(m==0)
                printf("1 ");
            else
            {
                for(int i=1; i<=30005; i++)
                {
                    if(pd[i]==1&&get(i)==get(0))
                        sum++;

                }
                printf("%d ",sum+1);
            }


           }
           return 0;
    }

  • 相关阅读:
    扩展Image组件,属性不显示
    unity ugui如何用scrollview展示多个不同的3d物体
    Unity 给模型添加子物体,跟随父物体移动和旋转时不同步问题
    Unity3D性能优化
    Vs2017安装不上个问题,愁了好久
    Time.timeScale 暂停游戏
    unity.3d 打开monodevelop无法调用命名空间问题
    Unity.3D中,两个界面各自脚本中的变量如何调用
    * 笔记标题及标签整体说明+md总结
    & 文件透传整理
  • 原文地址:https://www.cnblogs.com/13224ACMer/p/4414090.html
Copyright © 2011-2022 走看看