zoukankan      html  css  js  c++  java
  • poj2965枚举

    The Pilots Brothers' refrigerator
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 20398   Accepted: 7857   Special Judge

    Description

    The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

    There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

    The task is to determine the minimum number of handle switching necessary to open the refrigerator.

    Input

    The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

    Output

    The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

    Sample Input

    -+--
    ----
    ----
    -+--

    Sample Output

    6
    1 1
    1 3
    1 4
    4 1
    4 3
    4 4

    Source

     

     

     

     

    本题主要是当需要改变某个+为-时,需要将他所在的行与所在的列都需要反转一次,如果反转两次相当与没反,所以每一反转的情况便可以的

    最后判断%2时候的情况,==1便是需要反转的,否则不需要反转

    ‘#include<stdio.h>
    #include<string.h>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int temp[4][4],ans[4][4];
    char a[4][4];
    int main(){
       memset(temp,0,sizeof(temp));
       memset(a,0,sizeof(a));
       memset(ans,0,sizeof(ans));
       for(int i=0;i<4;i++){
          for(int j=0;j<4;j++){
             scanf("%c",&a[i][j]);
             if(a[i][j]=='+')
             temp[i][j]=1;
             else
             temp[i][j]=0;
          }
          getchar();
       }
       for(int i=0;i<4;i++){
         for(int j=0;j<4;j++){
            if(temp[i][j]==1){
               for(int k=0;k<4;k++){
                   ans[i][k]+=1;
                   ans[k][j]+=1;
               }
               ans[i][j]-=1;

            }
         }
       }
       int x[16],y[16];
       memset(x,0,sizeof(x));
      memset(y,0,sizeof(y));
       int count=0;
       for(int i=0;i<4;i++){
         for(int j=0;j<4;j++){
             if(ans[i][j]%2==1){
                 x[count]=i;
                 y[count]=j;
                 count++;
             }
         }
        }
        cout<<count<<endl;
        for(int i=0;i<count;i++){
           cout<<x[i]+1<<" "<<y[i]+1<<endl;
        }

       return 0;
    }

  • 相关阅读:
    操作系统的磁盘结构、磁盘管理、磁盘调度算法
    ArrayList源码解析--值得深读
    深入理解static、volatile关键字
    7:高阶张量操作
    6:统计属性
    5:张量的基本运算
    4.1张量的操作(broadcasting维度自动扩张,拼接与拆分)
    4:张量操作
    3:索引与切片
    2:pytorch的基本数据类型以及张量的创建
  • 原文地址:https://www.cnblogs.com/13224ACMer/p/4615851.html
Copyright © 2011-2022 走看看