zoukankan      html  css  js  c++  java
  • poj2632 模拟

    Crashing Robots
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 8388   Accepted: 3631

    Description

    In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving.
    A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

    Input

    The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction.
    The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively.
    Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position.

    Figure 1: The starting positions of the robots in the sample warehouse

    Finally there are M lines, giving the instructions in sequential order.
    An instruction has the following format:
    < robot #> < action> < repeat>
    Where is one of
    • L: turn left 90 degrees,
    • R: turn right 90 degrees, or
    • F: move forward one meter,

    and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

    Output

    Output one line for each test case:
    • Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.)
    • Robot i crashes into robot j, if robots i and j crash, and i is the moving robot.
    • OK, if no crashing occurs.

    Only the first crash is to be reported.

    Sample Input

    4
    5 4
    2 2
    1 1 E
    5 4 W
    1 F 7
    2 F 7
    5 4
    2 4
    1 1 E
    5 4 W
    1 F 3
    2 F 1
    1 L 1
    1 F 3
    5 4
    2 2
    1 1 E
    5 4 W
    1 L 96
    1 F 2
    5 4
    2 3
    1 1 E
    5 4 W
    1 F 4
    1 L 1
    1 F 20

    Sample Output

    Robot 1 crashes into the wall
    Robot 1 crashes into robot 2
    OK
    Robot 1 crashes into robot 2

    Source

     
     
     
     
     
     
    给跪了
    做的时候不到一个小时就完事了。结果找bug找了4个小时,就是一个变量写错了,怎么都找不到啊
     
    zuile,醉了
    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    using  namespace std;
    struct node{
        int x;
        int y;
        int z;
    }que[200];
    int next[4][2]= {0,1,-1,0,0,-1,1,0};
    int ans, tx,ty;

    int vis[105][105];
    int y,x;
    void update1(){
        int xx=que[tx].x;
        int yy=que[tx].y;
        int zz=que[tx].z;
        for(int i=1; i<=ty; i++){
            xx+=next[zz][0];
            yy+=next[zz][1];
            if(xx<1||xx>x||yy<1||yy>y){
                printf("Robot %d crashes into the wall ",tx);
                ans=1;
               return;
            }
             if(vis[xx][yy]!=0){
                printf("Robot %d crashes into robot %d ",tx,vis[xx][yy]);
                ans=1;
            return;
            }
        }
         vis[xx][yy]=tx;
        vis[que[tx].x][que[tx].y]=0;
        que[tx].x=xx;
        que[tx].y=yy;

    }
    void update2(){
          que[tx].z=(que[tx].z+ty%4)%4;
    }
    void update3(){
         que[tx].z=(que[tx].z-ty%4+4)%4;
    }
    int main(){
        int t,n,m;
        char c;
        scanf("%d",&t);
        while(t--){
            memset(vis,0,sizeof(vis));
            memset(que,0,sizeof(que));
            scanf("%d%d",&x,&y);
            scanf("%d%d",&n,&m);
            for(int i=1; i<=n; i++){
                scanf("%d %d %c",&que[i].x,&que[i].y,&c);
                if(c=='N')  que[i].z=0;
                 else  if(c=='W')     que[i].z=1;
                  else if(c=='S')    que[i].z=2;
                  else  if(c=='E')     que[i].z=3;
                  vis[que[i].x][que[i].y]=i;
            }
            ans=0;
            for(int i=1; i<=m; i++){
               scanf("%d %c %d",&tx,&c,&ty);
                if(ans==0){
                if(c=='F')
                    update1();
                else  if(c=='L')
                    update2();
                else  if(c=='R')
                    update3();
                }
            }
            if(ans==0)
                printf("OK ");

        }
        return 0;
    }

  • 相关阅读:
    【分享】Audio工程测试1080p yuv422 10bit编码,软件报告VCU能力不足
    VLC和Gstreamer配合
    【分享】在MPSoC ZCU106单板上运行Docker
    python之(25)中级总结(3)关系型数据库(mysql和oracle使用)
    python之(24)中级总结(2) 时间模块,json和xml模块学习总结
    Java从入门到实战之(33)Java中23种设计模式之5种创建式模式
    python之(23)中级总结(1) 正则表达式和内置函数学习总结
    python之(22)基础总结(5)
    SparkSQL构建用户画像
    Python机器学习(九十八)机器学习算法原理解析
  • 原文地址:https://www.cnblogs.com/13224ACMer/p/4628627.html
Copyright © 2011-2022 走看看