zoukankan      html  css  js  c++  java
  • poj1789 Truck History最小生成树

    Truck History
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 20768   Accepted: 8045

    Description

    Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

    Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
    1/Σ(to,td)d(to,td)

    where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 
    Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

    Input

    The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

    Output

    For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

    Sample Input

    4
    aaaaaaa
    baaaaaa
    abaaaaa
    aabaaaa
    0
    

    Sample Output

    The highest possible quality is 1/3.


    代码
    基本prim模板没什么可说的,只是需要将字符串预处理为邻接矩阵即可

    #include<stdio.h>
    #include<string.h>
    #include<iostream>
    using namespace std;
    int map[2005][2005];
    char str[2005][7];
    int vis[2005],dis[2005];
    int n;
    int prim(int u){
    int sum=0;
    for(int i=1;i<=n;i++){
    dis[i]=map[u][i];
    }
    vis[u]=1;
    for(int i=1;i<n;i++){
    int tmin=999999999;
    int ans;
    for(int j=1;j<=n;j++){
    if(dis[j]<tmin&&!vis[j]){
    tmin=dis[j];
    ans=j;
    }
    }
    sum+=tmin;
    vis[ans]=1;
    for(int k=1;k<=n;k++){
    if(dis[k]>map[ans][k]&&!vis[k])
    dis[k]=map[ans][k];
    }
    }
    return sum;
    }
    int main(){

    while(scanf("%d",&n)!=EOF){
    if(n==0)
    break;

    memset(map,0,sizeof(map));
    memset(str,0,sizeof(str));
    memset(dis,0,sizeof(dis));
    memset(vis,0,sizeof(vis));
    getchar();
    for(int i=1;i<=n;i++){
    scanf("%s",str[i]);
    getchar();

    }
    for(int i=1;i<=n;i++){
    for(int j=i;j<=n;j++){
    int sum=0;
    for(int k=0;k<7;k++){
    if(str[i][k]!=str[j][k])
    sum++;
    }
    map[i][j]=sum;
    map[j][i]=sum;
    }
    }
    printf("The highest possible quality is 1/%d. ",prim(1));
    }
    return 0;
    }

  • 相关阅读:
    两种序列化方式Serializable和Parcelable
    函数初识
    编码理解
    分享------关于复合赋值运算符
    pycharm 设置鼠标控制字体大小
    Mac下python3的安装和PyCharm中python3的使用
    python编码问题总结
    python----编码详解
    python基础二
    python 基础一
  • 原文地址:https://www.cnblogs.com/13224ACMer/p/4629809.html
Copyright © 2011-2022 走看看