zoukankan      html  css  js  c++  java
  • hdu 5444 构建二叉树,搜索二叉树

    Elven Postman

    Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
    Total Submission(s): 800    Accepted Submission(s): 429


    Problem Description
    Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.

    So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having the privilege to see the sunrise, which matters a lot in elven culture.

    Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

    Your task is to determine how to reach a certain room given the sequence written on the root.

    For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.

     
    Input
    First you are given an integer T(T10) indicating the number of test cases.

    For each test case, there is a number n(n1000) on a line representing the number of rooms in this tree. n integers representing the sequence written at the root follow, respectively a1,...,an where a1,...,an{1,...,n}.

    On the next line, there is a number q representing the number of mails to be sent. After that, there will be q integers x1,...,xq indicating the destination room number of each mail.
     
    Output
    For each query, output a sequence of move (E or W) the postman needs to make to deliver the mail. For that E means that the postman should move up the eastern branch and W the western one. If the destination is on the root, just output a blank line would suffice.

    Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.
     
    Sample Input
    2 4 2 1 4 3 3 1 2 3 6 6 5 4 3 2 1 1 1
     
    Sample Output
    E WE EEEEE
     
    Source
     
    Recommend
    hujie   |   We have carefully selected several similar problems for you:  5449 5448 5447 5445 5444 
     
    #include<stdio.h>
    #include<string.h>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    struct BRT{
      int date;
      BRT *left;
      BRT *right;
      BRT(){}
      BRT(int x):date(x){
          left=NULL;
          right=NULL;
      }
    };
    
    void build_tree(BRT *root,int x){
        if(x<root->date){
             if(root->left==NULL){
                  root->left=new BRT(x);
                 return ; 
             }
             build_tree(root->left,x);
        }
        else{
                if(root->right==NULL){
                  root->right=new BRT(x);
                 return ; 
             }
             build_tree(root->right,x);
        }
    }
    
    void get_path(BRT *root,int x){
        if(root->date==x){
           puts("");
           return ;
        }
        else if(x>root->date){
              printf("W");
              get_path(root->right,x);
        }
        else{
        printf("E");
        get_path(root->left,x);
        }
    
    }
    
    int main(){
       int t;
       scanf("%d",&t);
       while(t--){
           int n;
           scanf("%d",&n);
            int x;
            scanf("%d",&x);
            BRT *root=new BRT(x);
            for(int i=1;i<n;i++){
               scanf("%d",&x);
               build_tree(root,x);
            }        
            int q;
            scanf("%d",&q);
            
            for(int i=0;i<q;i++){
                scanf("%d",&x);
            get_path(root,x);    
            }
       }
       return 0;
    }
  • 相关阅读:
    打卡规则小模块设计
    json和ajax学习
    求两个数的百分比&时间格式化&ajax返回json
    spring security运行流程图(转)
    DelegatingFilterProxy作用浅析
    网站URL重写(Java UrlRewrite 的使用)
    JVM的常用的调优策略和垃圾回收算法及Tomcat的常用调优参数
    JQuery 的Ajax的使用
    servlet程序HTTP Status 500
    CanvasRenderingContext2D.drawImage()无效,not working
  • 原文地址:https://www.cnblogs.com/13224ACMer/p/4817506.html
Copyright © 2011-2022 走看看