zoukankan      html  css  js  c++  java
  • bzoj1620:时间管理

    1620: [Usaco2008 Nov]Time Management 时间管理

    Time Limit: 5 Sec  Memory Limit: 64 MB
    Submit: 571  Solved: 343
    [Submit][Status][Discuss]

    Description

    Ever the maturing businessman, Farmer John realizes that he must manage his time effectively. He has N jobs conveniently numbered 1..N (1 <= N <= 1,000) to accomplish (like milking the cows, cleaning the barn, mending the fences, and so on). To manage his time effectively, he has created a list of the jobs that must be finished. Job i requires a certain amount of time T_i (1 <= T_i <= 1,000) to complete and furthermore must be finished by time S_i (1 <= S_i <= 1,000,000). Farmer John starts his day at time t=0 and can only work on one job at a time until it is finished. Even a maturing businessman likes to sleep late; help Farmer John determine the latest he can start working and still finish all the jobs on time.

    N个工作,每个工作其所需时间,及完成的Deadline,问要完成所有工作,最迟要什么时候开始.

    Input

    * Line 1: A single integer: N

    * Lines 2..N+1: Line i+1 contains two space-separated integers: T_i and S_i

    Output

    * Line 1: The latest time Farmer John can start working or -1 if Farmer John cannot finish all the jobs on time.

    Sample Input

    4
    3 5
    8 14
    5 20
    1 16

    INPUT DETAILS:

    Farmer John has 4 jobs to do, which take 3, 8, 5, and 1 units of
    time, respectively, and must be completed by time 5, 14, 20, and
    16, respectively.

    Sample Output

    2

    OUTPUT DETAILS:

    Farmer John must start the first job at time 2. Then he can do
    the second, fourth, and third jobs in that order to finish on time.

    HINT

     

    Source

    Silver

    先排序一下,注意是排序完成的时间,然后用二分答案就ok了,感觉就是好像如果能用枚举的话用二分答案搞。

    我草草草草一直wa居然是因为一个点需要输出-1!!!看题看题看题看题!!!

    --------------------------------------------------------------------------------------------------

    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<iostream>
    using namespace std;
    int n;
    struct edge{
     int dis,to;
     bool operator<(const edge&rhs) const{
       return to<rhs.to;}
    };
    edge edges[1005];
    bool pd(int x){
        int ans=x;
     for(int i=1;i<=n;i++){
      edge &s=edges[i];
      ans+=s.dis;
         if(ans>s.to)
           return false;
     }
     return true;
    }
    int main(){
     scanf("%d",&n);
     int ans=-2;
     int l=0;int r=0x7fffffff;
     for(int i=1;i<=n;i++){
      scanf("%d%d",&edges[i].dis,&edges[i].to);
      r=min(r,edges[i].to);
     }
     sort(edges+1,edges+n+1);
     while(l<=r){
      int m=(l+r)/2;
         if(pd(m)){
          ans=m,l=m+1;
         }
         else
           r=m-1;
     }
     if(ans!=-2)
       printf("%d ",ans);
     else
       printf("-1");
     return 0;
    }

    -------------------------------------------------------------------------------

  • 相关阅读:
    leetcode 92. 反转链表 II
    leetcode记录1 快速排序
    Jmeter入门总结
    Jmeter 元件作用域、集合点、检查点
    Jmeter 实例
    badboy脚本开发
    Jmeter 常用功能介绍
    简单的自创线程池
    多线程
    IO多路复用
  • 原文地址:https://www.cnblogs.com/20003238wzc--/p/4805498.html
Copyright © 2011-2022 走看看