zoukankan      html  css  js  c++  java
  • bzoj1634:护花

    1634: [Usaco2007 Jan]Protecting the Flowers 护花

    Time Limit: 5 Sec  Memory Limit: 64 MB
    Submit: 556  Solved: 351
    [Submit][Status][Discuss]

    Description

    Farmer John went to cut some wood and left N (2 <= N <= 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cows were in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport the cows back to their barn. Each cow i is at a location that is Ti minutes (1 <= Ti <= 2,000,000) away from the barn. Furthermore, while waiting for transport, she destroys Di (1 <= Di <= 100) flowers per minute. No matter how hard he tries,FJ can only transport one cow at a time back to the barn. Moving cow i to the barn requires 2*Ti minutes (Ti to get there and Ti to return). Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.

       约翰留下他的N只奶牛上山采木.他离开的时候,她们像往常一样悠闲地在草场里吃草.可是,当他回来的时候,他看到了一幕惨剧:牛们正躲在他的花园里,啃食着他心爱的美丽花朵!为了使接下来花朵的损失最小,约翰赶紧采取行动,把牛们送回牛棚. 牛们从1到N编号.第i只牛所在的位置距离牛棚Ti(1≤Ti《2000000)分钟的路程,而在约翰开始送她回牛棚之前,她每分钟会啃食Di(1≤Di≤100)朵鲜花.无论多么努力,约翰一次只能送一只牛回棚.而运送第第i只牛事实上需要2Ti分钟,因为来回都需要时间.    写一个程序来决定约翰运送奶牛的顺序,使最终被吞食的花朵数量最小.

    Input

    * Line 1: A single integer

    N * Lines 2..N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow's characteristics

        1行输入N,之后N行每行输入两个整数TiDi

    Output

    * Line 1: A single integer that is the minimum number of destroyed flowers

        一个整数,表示最小数量的花朵被吞食.

    Sample Input

    6
    3 1
    2 5
    2 3
    3 2
    4 1
    1 6

    Sample Output

    86

    HINT

        约翰用623415的顺序来运送他的奶牛.

    Source

    Silver

    早上想了很久贪心贪心,然后贪心不出来就想dpdpdp于是一节语文课还是想不出来,然后看了题解发现其实想差了一点点,因为想的只是贪心一定要某个元素的特征满足,但是这个特征也是可以并不明显或者是推出来的;贪心应用

    -----------------------------------------------------------------------------

    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<iostream>
    #include<queue>
    using namespace std;
    struct node{
     int t,n;
     bool operator<(const node&rhs)const {
         return t*rhs.n<rhs.t*n;}
    };
    node e[100005];
    int main(){
     int m;
     long long sum=0,ans=0;
        scanf("%d",&m);
        for(int i=1;i<=m;i++){
           scanf("%d%d",&e[i].t,&e[i].n);
           sum+=e[i].n;
        }
        sort(e+1,e+m+1);
        for(int i=1;i<=m;i++){
           sum-=e[i].n;
           ans+=2*sum*e[i].t;
        }
        printf("%lld ",ans);
        return 0;
    }

    ---------------------------------------------------------------------------------------------

  • 相关阅读:
    springboot idea新建工程Initialization failed for 'https://start.spring.io' Please check URL, network and proxy settings
    TCP的三次握手与四次挥手理解及面试题
    lambda用法
    深入理解HashMap的扩容机制
    数据库连接池性能测试对比
    SQL
    AOP实现的统一日志处理
    阿里面试1
    汇总
    如果使用association和collection实现层级查询
  • 原文地址:https://www.cnblogs.com/20003238wzc--/p/4811321.html
Copyright © 2011-2022 走看看