zoukankan      html  css  js  c++  java
  • bzoj1636:Balanced Lineup

    1636: [Usaco2007 Jan]Balanced Lineup

    Time Limit: 5 Sec  Memory Limit: 64 MB
    Submit: 599  Solved: 423
    [Submit][Status][Discuss]

    Description

    For the daily milking, Farmer John's N cows (1 <= N <= 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height. Farmer John has made a list of Q (1 <= Q <= 200,000) potential groups of cows and their heights (1 <= height <= 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

    每天,农夫 John 的N(1 <= N <= 50,000)头牛总是按同一序列排队. 有一天, John 
    决定让一些牛们玩一场飞盘比赛. 他准备找一群在对列中为置连续的牛来进行比赛. 
    但是为了避免水平悬殊,牛的身高不应该相差太大. 
    John 准备了Q (1 <= Q <= 180,000) 个可能的牛的选择和所有牛的身高 (1 <= 
    身高 <= 1,000,000). 他想知道每一组里面最高和最低的牛的身高差别. 
    注意: 在最大数据上, 输入和输出将占用大部分运行时间. 

    Input

    * Line 1: Two space-separated integers, N and Q. * Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i * Lines N+2..N+Q+1: Two integers A and B (1 <= A <= B <= N), representing the range of cows from A to B inclusive.

    Output

    6 3
    1
    7
    3
    4
    2
    5
    1 5
    4 6
    2 2
     

    Sample Input

    * Lines 1..Q: Each line contains a single integer that is a response
    to a reply and indicates the difference in height between the
    tallest and shortest cow in the range.

    Sample Output

    6
    3
    0

    HINT

     

    Source

    Silver

    裸的线段树。然而从下午到晚上都在写单调队列然后愣是ac不了一道。。遂弃疗。。。然后突然写了一道题1a了。。。。

    ----------------------------------------------------------------------------------------------------------

    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<iostream>
    #include<deque>
    using namespace std;
    int nmin[200000],nmax[200000];
    int ql,qr,v,cur;
    void insert(int l,int r,int k){
       if(l==r){
           nmin[k]=v;
           nmax[k]=v;
           return;
     }
     int m=(l+r)/2;
     if(cur<=m)
          insert(l,m,2*k);
     else
          insert(m+1,r,2*k+1);
          nmin[k]=min(nmin[2*k],nmin[2*k+1]);
          nmax[k]=max(nmax[2*k],nmax[2*k+1]);
    }
    int findl(int l,int r,int k){
         if(ql<=l&&qr>=r)
             return nmax[k];
        int m=(l+r)/2;
        int ans=-0x7fffffff;
        if(qr>m)
             ans=max(ans,findl(m+1,r,2*k+1));
        if(ql<=m)
             ans=max(ans,findl(l,m,2*k));
        return ans;
    }
    int findr(int l,int r,int k){
        if(ql<=l&&qr>=r)
            return nmin[k];
        int m=(l+r)/2;
        int ans=0x7fffffff;
        if(qr>m)
            ans=min(ans,findr(m+1,r,2*k+1));
        if(ql<=m)
            ans=min(ans,findr(l,m,2*k));
        return ans;
    }
    int main(){

     int n,m;
     scanf("%d%d",&n,&m);
     for(int i=1;i<=n;i++){
          int tmp;
          scanf("%d",&tmp);
          v=tmp;
          cur=i;
          insert(1,n,1);
     }
     for(int i=1;i<=m;i++){
          scanf("%d%d",&ql,&qr);
          printf("%d ",findl(1,n,1)-findr(1,n,1));
     }
     return 0;
     }

    ---------------------------------------------------------------------------------------------------

  • 相关阅读:
    Neo4j ETL工具快速上手:简化从关系数据库到图数据库的数据迁移
    关于 Neo4j 属性个数的限制
    大数据、人工智能、知识图谱业务蓝图、技术架构-笔记
    数据库设计——评论回复功能
    搜索引擎和知识图谱那些事
    知识图谱在企业中的典型应用和注意事项
    这是一份通俗易懂的知识图谱技术与应用指南
    Qt实用技巧:使用QTableView、QSqlTableMode与QSqlDatabase对数据库数据进行操作
    Qt实用技巧:界面切换使用Dialog全屏切换
    pushbutton成为可点击的图标(实现全透明,不论点击与否都只显示Icon)(也就是一个万能控件)
  • 原文地址:https://www.cnblogs.com/20003238wzc--/p/4814390.html
Copyright © 2011-2022 走看看