zoukankan      html  css  js  c++  java
  • bzoj1646:抓住那只牛

    1646: [Usaco2007 Open]Catch That Cow 抓住那只牛

    Time Limit: 5 Sec  Memory Limit: 64 MB
    Submit: 829  Solved: 393
    [Submit][Status][Discuss]

    Description

    Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 <= N <= 100,000) on a number line and the cow is at a point K (0 <= K <= 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X-1 or X+1 in a single minute * Teleporting: FJ can move from any point X to the point 2*X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

        农夫约翰被通知,他的一只奶牛逃逸了!所以他决定,马上幽发,尽快把那只奶牛抓回来.
        他们都站在数轴上.约翰在N(O≤N≤100000)处,奶牛在K(O≤K≤100000)处.约翰有
    两种办法移动,步行和瞬移:步行每秒种可以让约翰从z处走到x+l或x-l处;而瞬移则可让他在1秒内从x处消失,在2x处出现.然而那只逃逸的奶牛,悲剧地没有发现自己的处境多么糟糕,正站在那儿一动不动.
        那么,约翰需要多少时间抓住那只牛呢?

    Input

    * Line 1: Two space-separated integers: N and K

        仅有两个整数N和K.

    Output

    * Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

        最短的时间.

    Sample Input

    5 17
    Farmer John starts at point 5 and the fugitive cow is at point 17.

    Sample Output

    4

    OUTPUT DETAILS:

    The fastest way for Farmer John to reach the fugitive cow is to
    move along the following path: 5-10-9-18-17, which takes 4 minutes.

    HINT

     

    Source

    Silver

    就是简单的bfs吧。然后就是开始不知道要最大到哪里就停止,然后想到其实很明显,每一个点到达另一个点都可以有两种方法,然后ac了

    ---------------------------------------------------------------------------------

    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #include<queue>
    using namespace std;
    int n,m,maxn;
    const int nmax=100005;
    int q[nmax],v[nmax],d[nmax];
    int main(){
     scanf("%d%d",&n,&m);
     maxn=max(n,m)+1;
     memset(d,0x7f,sizeof(d));
     memset(v,0,sizeof(v));
     int l=0;int r=1;
        q[0]=n;
        v[n]=1;
        d[n]=0;
     while(l!=r){
      int tmp=q[l];
      l++;
      if(l==nmax) l=0;
      int dis=d[tmp]+1;
      if(tmp-1>=0&&d[tmp-1]>dis){
       d[tmp-1]=dis;
       if(tmp-1==m)
         break;
       if(!v[tmp-1]){
        v[tmp-1]=1;
        q[r++]=tmp-1;
        if(r==100000)
          r=0;
       }
      }
         if(tmp+1<=maxn&&d[tmp+1]>dis){
          d[tmp+1]=dis;
          if(tmp+1==m)
            break;
          if(!v[tmp+1]){
           v[tmp+1]=1;
           q[r++]=tmp+1;
           if(r==100000)
             r=0;
          }
         }
         if(tmp*2<=maxn&&d[tmp*2]>dis){
          d[tmp*2]=dis;
          if(tmp*2==m)
            break;
          if(!v[tmp*2]){
           v[tmp*2]=1;
           q[r++]=tmp*2;
           if(r==100000)
             r=0;
          }
         }
     }
     printf("%d ",d[m]);
     return 0;
    }

    -----------------------------------------------------------------------------------

  • 相关阅读:
    Java基础系列——IO流
    如何为网站添加 CSS 暗模式(转载)
    详解 UWP (通用 Windows 平台) 中的两种 HttpClient API
    微软微服务架构 eShopOnContainers
    web开发中使用html/css全屏铺开显示
    web开发中的Cookie
    WPF依赖属性Binding实现
    SQL Server2014安装流程及注意事项
    .Net配置文件读取及修改方法封装(未加密)
    WCF开发优秀博客园推荐
  • 原文地址:https://www.cnblogs.com/20003238wzc--/p/4819084.html
Copyright © 2011-2022 走看看