zoukankan      html  css  js  c++  java
  • POJ 3267 The Cow Lexicon 动态规划

    The Cow Lexicon
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 6999   Accepted: 3242

    Description

    Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

    The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

    Input

    Line 1: Two space-separated integers, respectively: W and L  Line 2: L characters (followed by a newline, of course): the received message  Lines 3..W+2: The cows' dictionary, one word per line

    Output

    Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

    Sample Input

    6 10
    browndcodw
    cow
    milk
    white
    black
    brown
    farmer

    Sample Output

    2
    代码:
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std ;
    #define MAXN 610
    #define MAX 310
    char word[MAX] ;
    char a[MAXN][MAXN] ;
    int len[MAXN] ,dp[MAXN] ;
    int main()
    {
    	int i , j , n , m ;
    	int k , p ;
    	while( scanf( "%d%d" ,&n , &m ) != EOF )
    	{
    		cin >> word ;
    		for( i = 1; i <= n ;i++)
    		{
    			scanf( "%s" , a[i] ) ;
    			len[i] = strlen( a[i] ) ;
    		}
    		memset( dp , 0 ,sizeof(dp) ) ;
    		for( i = 1 ; i <= m ; i++)
    		{
    			dp[i] = dp[i-1] + 1 ; // 如果不匹配就是加一
    			for( j = 1 ;j <= n ;j++)
    			{
    				k = len[j] - 1 ;
    				p = i - 1;
    				while( k >= 0 && p >= 0)
    				{
    					if( a[j][k] == word[p] )
    					{
    						k-- ;
    					}
    					p-- ;
    				}
    				if( k < 0 )
    				{
    					dp[i] = min(dp[i], dp[p + 1] + i - p - 1 - len[j]);   
    					// i - p - 1 - len[j] 是第j个单词匹配成功时要去掉的单词数
    					// 转移方程 dp[i] = min( dp[i] ,dp[p+1]+i - p - 1 - len[j] )
    					// 既 取 (第i 个不匹配) 和 (匹配)两者 去掉字符的最小值
    				}
    			}
    		}
    		cout << dp[m] << endl ;
    	}
    }
    

      

  • 相关阅读:
    很牛逼的android真机调试,手机、平板、电视都可
    设置TextView文字居中
    设置文本编辑器的按回车时触发的事件
    windows搭建virtualbox虚拟机安装的android环境
    Android EditText不弹出输入法焦点问题的总结
    MAVEN 的常用命令
    PuTTY_0.67.0.0工具链接linux
    CentOS6.8安装
    互亿无线短信验证码
    MYSQL: sql中某一个字段内容为用逗号分割的字符串转换成多条数据
  • 原文地址:https://www.cnblogs.com/20120125llcai/p/3067823.html
Copyright © 2011-2022 走看看