zoukankan      html  css  js  c++  java
  • POJ 1742 Coins 多重背包

    Coins
    Time Limit: 3000MS   Memory Limit: 30000K
    Total Submissions: 24891   Accepted: 8419

    Description

    People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.  You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

    Input

    The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

    Output

    For each test case output the answer on a single line.

    Sample Input

    3 10
    1 2 4 2 1 1
    2 5
    1 4 2 1
    0 0
    

    Sample Output

    8
    4
    代码:
    #include<cstdio>
    #include<iostream>
    #include<cstring>
    using namespace std ;
    #define MAX 100010
    #define M 110
    int  v[M] , c[M] ;
    int mun[MAX] ;
    bool vi[MAX] ;
    int main()
    {
    	int i , j , n , m ;
    	int ans ;
    	while( scanf( "%d%d" , &n , &m ) != EOF )
    	{
    		if( n == 0 || m == 0 ) break ;
    		for( i = 1; i <= n ; i++) 
    			scanf( "%d" , &v[i] ) ;
    		for( i = 1 ; i <= n ;i++)
    			scanf( "%d" , &c[i] ) ;
    		memset( vi , 0 , sizeof(vi) ) ;
    		ans = 0 ;
    		vi[0] = 1 ;
    		for( i = 1 ; i <= n ;i++)
    		{
    			for( j = 0 ; j <= m ; j++ ) 
    				mun[j] = 0 ;// mun[] 是用当前硬币数量,所以每次都要初始化
    
    			for( j = v[i] ; j <= m ; j++)
    			{
    				if( !vi[j] && vi[j-v[i]] && mun[j-v[i]] < c[i])
    				{// 如果j-v[i]已经能组成而且组成它的数量少于当前硬币的数量
    				 // 说明当前 的总量肯定能组成,
    					vi[j] = 1 ;
    					mun[j] = mun[j-v[i]] + 1 ;
    					ans++ ;
    				}
    			}
    		}
    		cout << ans << endl ;
    	} 
    }
    

      

  • 相关阅读:
    使用 HTML5 可以做的五件很棒的事情
    分享最新20款非常棒的 CSS 工具
    最新17个紫色风格网页设计作品欣赏
    最新70佳很酷的名片设计作品欣赏
    50个优秀的名片设计作品欣赏
    推荐12个漂亮的CSS3按钮实现方案
    推荐10个很棒的 CSS3 开发工具
    30个复古风格的网页设计作品欣赏
    非常流行的十款 jQuery 插件推荐
    20个漂亮的WordPress作品集主题分享
  • 原文地址:https://www.cnblogs.com/20120125llcai/p/3067850.html
Copyright © 2011-2022 走看看