zoukankan      html  css  js  c++  java
  • POJ 1836 Alignment 最长上升子序列变形

    Alignment
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 10545   Accepted: 3375

    Description

    In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 
    Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

    Input

    On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 
    There are some restrictions:  • 2 <= n <= 1000  • the height are floating numbers from the interval [0.5, 2.5] 

    Output

    The only line of output will contain the number of the soldiers who have to get out of the line.

    Sample Input

    8
    1.86 1.86 1.30621 2 1.4 1 1.97 2.2
    

    Sample Output

    4
    代码:
    #include<cstdio>
    #include<iostream>
    #include<cstring>
    using namespace std ;
    #define MAX 1010
    #define we 1e-6// 处理精度误差
    double a[MAX] , ans1[MAX] , ans2[MAX];
    int vi[MAX] ;// vi[i]标记当前的 i 是不是被用两次
    int sum[MAX] ;
    int find( int s , int e , double w )
    {
    
    	 if( s == e ) return s ;	
    	 int mid = ( s + e ) / 2 ;
         if( w - ans1[mid] > we ) return find( mid + 1 ,e , w ) ;
    	else return find( s , mid , w ) ;
    
    } 
    int find1( int s , int e , double w )
    {
    
    	 if( s == e ) return s ;	
    	 int mid = ( s + e ) / 2 ;
         if( w - ans2[mid] > we ) return find1( mid + 1 ,e , w ) ;
    	else return find1( s , mid , w ) ;
    
    } 
    int main()
    {
    	int i , len , n , j ;
    	while( scanf( "%d" , &n ) != EOF  )
    	{
    		for( i = 1 ; i <= n ;i++){
    			scanf( "%lf" , &a[i] ) ;
    		}
    		len = 0 ;
    		memset( vi , 0 , sizeof(vi) ) ;
    		ans1[0] = -12212 ;
    		for( i = 1 ; i <= n ;i++)
    		{
    			if( a[i] - ans1[len] > we ) { vi[i] = 1 ;j = ++len ;}
    			else j = find( 1 , len , a[i] ) ;
    			ans1[j] = a[i] ;
    			sum[i] = len ;
    		}
    		ans2[0] = -239 ;len = 0 ;
            for( i = n ; i >= 1 ; i--)
    		{
    			if( a[i] - ans2[len] > we ) { vi[i] += 1 ;j = ++len ;}
    			else j = find1( 1 , len , a[i] ) ;
    			ans2[j] = a[i] ;
    			if( vi[i] == 2 ) sum[i] += ( len - 1) ;
    			else sum[i] += len ;
    		}
    		int Max = 0 ;
    		for( i = 1; i <= n ;i++)
    		{
    			if( Max < sum[i] ) 
    				Max = sum[i] ; 
    		}
    		printf(  "%d\n" , n - Max ) ; 
    	}
    }
    

      

  • 相关阅读:
    TestNG
    K近邻算法
    Python解决乱码问题
    Log4J 配置
    多线程死锁
    hadooplzo安装出错的解决方法
    B树
    设计模式
    整数序列化
    Maven
  • 原文地址:https://www.cnblogs.com/20120125llcai/p/3067875.html
Copyright © 2011-2022 走看看