zoukankan      html  css  js  c++  java
  • POJ 2796 Feel Good

    Time Limit: 3000MS   Memory Limit: 65536K
    Total Submissions: 8030   Accepted: 2170
    Case Time Limit: 1000MS   Special Judge

    Description

    Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life. 
    A new idea Bill has recently developed assigns a non-negative integer value to each day of human life. 
    Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day. 
    Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.

    Input

    The first line of the input contains n - the number of days of Bill's life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, ... an ranging from 0 to 106 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.

    Output

    Print the greatest value of some period of Bill's life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill's life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.

    Sample Input

    6
    3 1 6 4 5 2
    

    Sample Output

    60
    3 5
    代码:
    #include<cstdio>
    #include<iostream>
    #define MAXN 100010
    using namespace std ;
    int st[MAXN] , a[MAXN] ;
    int le[MAXN] , re[MAXN] ;
    long long  sum[MAXN] ;
    int main()
    {
        int i , n , m ,j ;
        long long ans = -1  , Sum = 0 ;
        while( scanf( "%d" , &n ) != EOF )
        {
            for( i = 1 ; i <= n ;i++)
                scanf( "%d" , &a[i] ) ;
            sum[0] = 0 ;Sum = 0 ;
            for( i = 1 ; i <= n ;i++)
                sum[i] = sum[i-1] + a[i] ;
            int top = 1 ;
            st[1] = 0 ;a[0] = -1 ; a[n+1] = -1 ;
            // 下面的两个循环式求出以a[i]为最小数的向右和向左延伸
            //数据结构式建立一个单调栈
            for( i = 1 ; i <= n ;i++)
            {
                while( a[st[top]] >= a[i]) top-- ;
                le[i] = st[top] ; 
                st[++top] = i ;
            }
            top = 1 ; st[1] = n + 1 ;ans = -1 ;
            for( i = n ; i >= 1 ; i--)
            {
                while( a[st[top]] >= a[i] ) top-- ;
                re[i] = st[top] ;
                st[++top] = i ;
            }
            int id ;
            for( i = 1 ; i <= n ;i++)
            {
                Sum = ( sum[re[i]-1] - sum[le[i]+1] + a[le[i]+1] ) * ( long long )a[i] ;
                if( Sum > ans )
                {
                    ans = Sum ;
                    id = i ;
                    //cout << le[id] + 1 << " " << id << " " << re[id] - 1 << endl ;
                }
            }
            printf( "%lld\n%d %d\n" , ans , le[id] + 1 , re[id] - 1 ) ;
        }
    }
  • 相关阅读:
    WEBUS2.0 In Action
    WEBUS2.0 In Action
    WEBUS2.0 In Action
    WEBUS2.0 In Action
    在Linux查看版本命令
    Increasing heap size while building the android source code on Ubuntu 15.10
    在Linux中增加swap空间
    Patch
    使用Vim比较两个文件的内容
    @override 重写 与重载
  • 原文地址:https://www.cnblogs.com/20120125llcai/p/3072554.html
Copyright © 2011-2022 走看看