zoukankan      html  css  js  c++  java
  • hdu 1394 Minimum Inversion Number

    Minimum Inversion Number

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 6815    Accepted Submission(s): 4158


    Problem Description
    The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

    For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

    a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
    a2, a3, ..., an, a1 (where m = 1)
    a3, a4, ..., an, a1, a2 (where m = 2)
    ...
    an, a1, a2, ..., an-1 (where m = n-1)

    You are asked to write a program to find the minimum inversion number out of the above sequences.
     
    Input
    The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
     
    Output
    For each case, output the minimum inversion number on a single line.
     
    Sample Input
    10 1 3 6 9 0 8 5 7 4 2
     
    Sample Output
    16
    代码 +  注释 
    #include<cstdio>
    #include<iostream>
    #include<cstring>
    #include<string>
    #define maxn 5001
    using namespace std ;
    int xt[maxn] , a[maxn];
    int low( int x )
    {
    	return x & (-x) ;
    }
    void up( int x )
    {
    	while( x <= maxn )
        { 
    		xt[x] += 1 ;
    		x += low(x) ;
    	}
    }
    int sum( int x )
    {
    	int ans = 0 ;
    	while( x > 0 )
    	{
    		ans += xt[x] ;
    		x -= low(x) ;
    	}
    	return ans ;
    }
    int main()
    {
    	int i , j , n ,ans , T , m = 0 ;
    	while(scanf( "%d" , &n ) !=EOF )
    	{
    		memset( xt , 0 ,sizeof(xt) ) ;
    		ans = 0 ;
    		for( i = 1 ; i <= n ;i++ )
    		{
    			scanf( "%d" , &a[i] ) ;
    			a[i]+=2 ;
    			up(a[i]) ;
    			ans += i - sum(a[i]-1) - 1 ;
    		}
    		m = ans ;
    		for( i = 1 ;i < n ;i++ ){
    			a[i] -= 2 ;
    			// 下面是规律
    	    	 m = m + (n - 1 - a[i]) - a[i];  
                if( m < ans)  
                    ans = m ;  			
    		}
    		printf( "%d\n" , ans ) ;
    	}
    }
    

      

     
  • 相关阅读:
    flutter 布局
    常见错误
    xpath
    bzoj1485 [HNOI2009]有趣的数列 卡特兰数
    博弈 Nim问题 POJ2234
    bzoj 1014 [JSOI2008]火星人prefix
    codevs 1743 反转卡片 rope or splay
    bzoj 2326 矩阵乘法
    bzoj 1702 贪心,前缀和
    bzoj 1700 Problem Solving 解题 dp
  • 原文地址:https://www.cnblogs.com/20120125llcai/p/3119473.html
Copyright © 2011-2022 走看看