最小公倍数
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 11 Accepted Submission(s) : 2
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
给定两个正整数,计算这两个数的最小公倍数。
Input
输入包含多组测试数据,每组只有一行,包括两个不大于1000的正整数.
Output
对于每个测试用例,给出这两个数的最小公倍数,每个实例输出一行。
Sample Input
10 14
Sample Output
70
Source
POJ
代码: #include<iostream> using namespace std;
int main()
{ int a,b;
while(cin>>a>>b)
{int k;
if(a>=b)
{ k=a;
while(k%a!=0||k%b!=0)
{ k++; }
} else
{ k=b;
while(k%a!=0||k%b!=0)//不能同时整除 a 和 b
{ k++; }
}
cout<<k<<endl; }
return 0; }