zoukankan      html  css  js  c++  java
  • hdu 1062 Text Reverse

    Text Reverse

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 16428    Accepted Submission(s): 6237

    Problem Description
    Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
     
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains a single line with several words. There will be at most 1000 characters in a line.
     
    Output
    For each test case, you should output the text which is processed.
     
    Sample Input
    3
    olleh !dlrow
    m'I morf .udh
    I ekil .mca
     
    Sample Output
    hello world!
    I'm from hdu.
    I like acm.

    #include <iostream>

    using namespace std;

    int main()

    {

               int n;  

                         cin>>n;  

                        getchar();

                        while(n--)  

       {  

                 char a[1005];

                           gets(a);   

                       int i,j,k;  

                for(i=0;i<strlen(a);i++)   

             {   

                      if(a[i]!=' ')    

                         {     for(j=i;a[j]!=' '&&j<strlen(a);j++);   

                                 for(k=j-1;k>=i;k--)                 cout<<a[k];

                                             i=j-1;       

                                }    

                                        else cout<<" ";   

                 }   

                        cout<<endl;     

     return 0;

    }

  • 相关阅读:
    Rotate Image,N*N矩阵顺时针旋转90度
    JumpGame,JumpGame2
    WildcardMatching和Regex,通配符匹配和正则表达式匹配
    Multiply Strings,字符串相乘
    TrappingRainWater
    300万PV的ASP.NET网站使用阿里云的配置建议
    java 学习 安卓学习
    如何学习Yii
    Lemon开源OA
    JAVA-进行Java Web项目开发需要掌握的技术
  • 原文地址:https://www.cnblogs.com/2014acm/p/3876536.html
Copyright © 2011-2022 走看看