zoukankan      html  css  js  c++  java
  • Virtual Friends(并查集+map)

    Virtual Friends

    Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
    Total Submission(s) : 70   Accepted Submission(s) : 29

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends. 

    Your task is to observe the interactions on such a website and keep track of the size of each person's network. 

    Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.

    Input

    Input file contains multiple test cases. 
    The first line of each case indicates the number of test friendship nest.
    each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).

    Output

    Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.

    Sample Input

    1
    3
    Fred Barney
    Barney Betty
    Betty Wilma
    

    Sample Output

    2
    3
    4

    Source

    University of Waterloo Local Contest 2008.09
     
    题意非常简单。
    有一个注意的地方就是1 那个是多组输入。。
    wa了好多发
    #include<iostream>
    #include<map>
    #include<stdio.h>
    using namespace std;
    int par[100005],num[100005];
    int findi(int x)
    {
        if(par[x]==x)
         return x;
        return par[x]=findi(par[x]);
    }
    void unioni(int x,int y)
    {
        int xx=findi(x);
        int yy=findi(y);
        if(xx==yy)
            cout<<num[xx]<<endl;
        else
        {
            par[xx]=yy;
            num[yy]=num[yy]+num[xx];
            cout<<num[yy]<<endl;
        }
    
    }
    int main()
    {
        int n;
        while(cin>>n)
        {
    
        map<string,int >ren;
        while(n--)
        {
            ren.clear();
            for(int i=1;i<=100000;i++)
            {
                par[i]=i;
                num[i]=1;
            }
            int m;
            cin>>m;
            string a,b;
            int t=1;
            for(int i=0;i<m;i++)
            {
                cin>>a>>b;
                if(ren[a]==0)
                    ren[a]=t++;
                if(ren[b]==0)
                    ren[b]=t++;
                 int x=ren[a];
                 int y=ren[b];
                  unioni(x,y);
            }
        }
        }
        return 0;
    }
  • 相关阅读:
    PHP $_POST 变量
    PHP $_GET 变量
    PHP 完整表单实例
    PHP 表单
    PHP 表单
    PHP 表单验证
    00_前情回顾
    18_今日回顾
    VMware 12PRO安装Mac OS X 10.10.5
    05_传智播客iOS视频教程_第一个OC程序
  • 原文地址:https://www.cnblogs.com/2014slx/p/7237098.html
Copyright © 2011-2022 走看看