zoukankan      html  css  js  c++  java
  • 浙江大学数据结构:01-复杂度2 Maximum Subsequence Sum (25分)

    浙江大学数据结构:01-复杂度2 Maximum Subsequence Sum (25分)

    Given a sequence of K integers { N1​​, N2​​, ..., NK​​ }. A continuous subsequence is defined to be { Ni​​, Ni+1​​, ..., Nj​​ } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:

    10
    -10 1 2 3 4 -5 -23 3 7 -21

    Sample Output:

    10 1 4
     
    提交代码:
    #include <stdio.h>
    #include <stdlib.h>
    #define MAXSIZE 10000
    int arr[MAXSIZE];
    
    int main(){
        int N;
        scanf("%d", &N);
        for(int i = 0; i < N; ++i){
            scanf("%d",arr+i);
        }
        int nMax = -1;
        int nSum = 0;
        int nFirst = 0;
        int nMaxSumFirst = 0;
        int nMaxSumLast =0;
        for(int i = 0; i < N; ++i){
            nSum+=arr[i];
            if(nSum > nMax){
                nMax = nSum;
                nMaxSumFirst = nFirst;
                nMaxSumLast = i;
            }
            if(nSum < 0)
            {
                nSum = 0;
                nFirst = i + 1;
            }
        }
        if(nMax == -1){
            printf("%d %d %d", 0, arr[0], arr[N-1]);
        }
        else{
            printf("%d %d %d", nMax, arr[nMaxSumFirst], arr[nMaxSumLast]);
        }
        return 0;
    }

    提测结果:

  • 相关阅读:
    移动网络介绍
    统一导航路由方案
    负载均衡汇总
    Openfire部署和配置说明
    CDN技术介绍
    流媒体
    WebSocket和HTTP的区别与联系
    zabbix 邮件报警
    Linux系统故障-Repair filesystem
    redhat 6.8 配置yum源
  • 原文地址:https://www.cnblogs.com/2018shawn/p/13775770.html
Copyright © 2011-2022 走看看