zoukankan      html  css  js  c++  java
  • 杭电OJ1062---Text Reverse(c++)(C++库getline的使用)

    Text Reverse

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 54493    Accepted Submission(s): 20797


     

    Problem Description
    Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
     
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains a single line with several words. There will be at most 1000 characters in a line.
     
    Output
    For each test case, you should output the text which is processed.
     
    Sample Input
     
    3 olleh !dlrow m'I morf .udh I ekil .mca
     
    Sample Output
     
    hello world! I'm from hdu. I like acm.
    Hint

    Remember to use getchar() to read ' ' after the interger T, then you may use gets() to read a line and process it.

    题解:

    #include<cstdio>
    #include<iostream>
    #include<cmath>
    #include<string>
    using namespace std;
    int main()
    {
        int n;
        cin >> n;
        getchar();
        while (n--)
        {
            int k = 0;
            string str;
            getline(cin,str);
            for (int i = 0; i<str.length();i++)
            {
                if (str[i] == ' ')
                {
                    for (int m = i - 1; m >= k; m--)
                    {
                        cout << str[m];
                    }
                    cout << " ";
                    k = i + 1;
                }
            }
                for (int m = str.length()- 1; m >=k; m--)
                    cout << str[m];
                cout << endl;
        }
        return 0;
    }

     

    永远热泪盈眶。
  • 相关阅读:
    [日志]“著名”炒股实用口诀
    Taven教授:解决失眠的好办法
    [日志]挂在树上的茶壶
    [日志]教你把脉知生男生女
    [日志]看了很多次的十句话
    [健康]国家制定公布甲型流感中药方市民可食用预防
    初学者如何开发出高质量J2EE系统
    学老中医的顺口溜防病
    [健康]巧用药茶疗慢性咽炎
    [日志]说一个人长的丑!如何说?
  • 原文地址:https://www.cnblogs.com/2021WGF/p/14253246.html
Copyright © 2011-2022 走看看