zoukankan      html  css  js  c++  java
  • 杭电OJ1062---Text Reverse(c++)(C++库getline的使用)

    Text Reverse

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 54493    Accepted Submission(s): 20797


     

    Problem Description
    Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
     
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains a single line with several words. There will be at most 1000 characters in a line.
     
    Output
    For each test case, you should output the text which is processed.
     
    Sample Input
     
    3 olleh !dlrow m'I morf .udh I ekil .mca
     
    Sample Output
     
    hello world! I'm from hdu. I like acm.
    Hint

    Remember to use getchar() to read ' ' after the interger T, then you may use gets() to read a line and process it.

    题解:

    #include<cstdio>
    #include<iostream>
    #include<cmath>
    #include<string>
    using namespace std;
    int main()
    {
        int n;
        cin >> n;
        getchar();
        while (n--)
        {
            int k = 0;
            string str;
            getline(cin,str);
            for (int i = 0; i<str.length();i++)
            {
                if (str[i] == ' ')
                {
                    for (int m = i - 1; m >= k; m--)
                    {
                        cout << str[m];
                    }
                    cout << " ";
                    k = i + 1;
                }
            }
                for (int m = str.length()- 1; m >=k; m--)
                    cout << str[m];
                cout << endl;
        }
        return 0;
    }

     

    永远热泪盈眶。
  • 相关阅读:
    【转】嵌入式软件:C语言编码规范
    【转】如何建立编码规范?
    RAS使用拨号网络拨号的类
    UDP 通讯代码
    【转】heap与stack的区别
    关于textarea在safari chrome下可拖动大小的问题
    Java网络编程入门
    诺基亚发布了它的第一台android手机,x和x+机型
    Spring学习笔记之入门(二)
    Spring学习笔记之入门(一)
  • 原文地址:https://www.cnblogs.com/2021WGF/p/14253246.html
Copyright © 2011-2022 走看看