zoukankan      html  css  js  c++  java
  • 杭电OJ2039——三角形(c++)(易错题:数据类型不确定)

    三角形

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 156024    Accepted Submission(s): 50080


     

    Problem Description
    给定三条边,请你判断一下能不能组成一个三角形。
     
    Input
    输入数据第一行包含一个数M,接下有M行,每行一个实例,包含三个正数A,B,C。其中A,B,C <1000;
     
    Output
    对于每个测试实例,如果三条边长A,B,C能组成三角形的话,输出YES,否则NO。
     
    Sample Input
     
    2 1 2 3 2 2 2
     
    Sample Output
     
    NO YES

    题解:

    #include<cstdio>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int main()
    {
        double n,s[3];
        cin >> n;
        while (n)
        {
            for (int j = 0; j < 3; j++)
                cin >> s[j];
            sort(s, s + 3);
            if (s[0] + s[1] > s[2])
                cout << "YES"<<endl;
            else
                cout << "NO"<<endl;
            n--;
        }
        return 0;
    }

    易错点:输入数据用 int,应该改为double

    永远热泪盈眶。
  • 相关阅读:
    Java线程
    IO流
    staitc
    权限修饰符
    nexus
    Maven
    Git 常用命令
    获取url参数
    创建存储过程和函数
    三层引号
  • 原文地址:https://www.cnblogs.com/2021WGF/p/14253248.html
Copyright © 2011-2022 走看看