zoukankan      html  css  js  c++  java
  • Train Problem I(HDU1022)

    As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
     


     

    Input
    The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
     
    Output
    The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
    Sample Input
    3 123 321 3 123 312
     
    Sample Output
    Yes.
    in
    in
    in
    out
    out
    out
    FINISH
    No.
    FINISH
    //这是简单的栈应用,先进先出原则。

    #include <stdio.h>
    #include <string.h>
    int main
    ()
    {
     int n,i,j,k,t,r[23],stack[13];
      char
     si[13],so[13];
      while
    (scanf("%d",&n)!=EOF)
      {

          getchar();
          memset(r,0,sizeof(r));
          memset(stack,0,sizeof(stack));
          scanf("%s%s",si,so);
          stack[1]=si[0];r[0]=1;
          for
    (k=t=j=1,i=0;so[i]!='\0';i++)
           {

              while
    (t<n)
              {

                if
    (j>0&&stack[j]==so[i]) //出栈
                {

                   j--;
                  r[k++]=2;//记录进出栈的情况
                  break
    ;
                }

                stack[++j]=si[t++];//进栈
                r[k++]=1; //记录进出栈的情况
              }

             if
    (stack[j]==so[i])//出栈
            {

                j--;
                r[k++]=2; //记录进出栈的情况
            }
         }


           n=n<<1;
           if
    (k<n)
             printf("No.\nFINISH\n");//这里开始比较郁闷的,No写成了大写还有下面的Yes,唉悲剧!
           else

             {
       printf("Yes.\n");
                 for
    (i=0;i<k;i++)
                   switch
    (r[i])
                   {

                       case
     1:printf("in\n");break;
                       case
     2:printf("out\n");break;
                   }

                 printf("FINISH\n");
             }
      }

      return
     0;
    }

                                                          -----------江财小子

  • 相关阅读:
    BZOJ 4445 [Scoi2015]小凸想跑步:半平面交
    BZOJ 3931 [CQOI2015]网络吞吐量:最大流【拆点】
    BZOJ 3698 XWW的难题:有上下界的最大流
    AtCoder ARC097C Sorted and Sorted:dp
    BZOJ 1835 [ZJOI2010]base 基站选址:线段树优化dp
    BZOJ 3329 Xorequ:数位dp + 矩阵快速幂
    BZOJ 1492 [NOI2007]货币兑换Cash:斜率优化dp + cdq分治
    BZOJ 4726 [POI2017]Sabota?:树形dp
    BZOJ 1185 [HNOI2007]最小矩形覆盖:凸包 + 旋转卡壳
    存一些东西
  • 原文地址:https://www.cnblogs.com/372465774y/p/2421641.html
Copyright © 2011-2022 走看看