zoukankan      html  css  js  c++  java
  • HDU 1028 Ignatius and the Princess III

    "Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

    "The second problem is, given an positive integer N, we define an equation like this:
      N=a[1]+a[2]+a[3]+...+a[m];
      a[i]>0,1<=m<=N;
    My question is how many different equations you can find for a given N.
    For example, assume N is 4, we can find:
      4 = 4;
      4 = 3 + 1;
      4 = 2 + 2;
      4 = 2 + 1 + 1;
      4 = 1 + 1 + 1 + 1;
    so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
     
    Input
    The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
     
    Output
    For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
     
    Sample Input
    4 10 20
     
    Sample Output
    5 42 627
     
    #include <iostream>
    #include <cstdio>
    using namespace std;
    int a[123],b[123];
    int main()
    {//freopen("in.txt","r",stdin);
     int i,j,k;
     for(i=0;i<=120;i++)
       a[i]=b[i]=1;
        for(k=2;k<=120;k++)
        {
          for(j=k;j<=120;j+=k)  //母函数基本模板
             for(i=0;i+j<=120;i++)
                   a[i+j]+=b[i];
          for(i=0;i<=120;i++)
                  b[i]=a[i];
        }
    while(scanf("%d",&i)!=EOF)
       printf("%d\n",a[i]);
     return 0;
    }
  • 相关阅读:
    期望dp专题
    Open Flash Chart 简介
    Open Flash Chart图表的JSON格式基本属性详解
    Open Flash Chart图表的JSON格式基本属性详解
    Open Flash Chart2 常用的参数
    Open Flash Chart2 常用的参数
    Chrome资源嗅探器应用
    Chrome资源嗅探器应用
    WebDev.WebServer40.EXE
    WebDev.WebServer40.EXE
  • 原文地址:https://www.cnblogs.com/372465774y/p/2429814.html
Copyright © 2011-2022 走看看